Lego.Ev3.Core Namespace

Lego.Ev3.Core Namespace LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Core classes for the EV3 API.
Classes
 | Class | Description
Public class | Brick | Main EV3 brick interface
Public class | BrickButtons | Buttons on the face of the LEGO EV3 brick
Public class | BrickChangedEventArgs | Arguments for PortsChanged event
Public class | Command | Command or chain of commands to be written to the EV3 brick
Public class | DirectCommand | Direct commands for the EV3 brick
Public class | DummyCommunication | Dummy object for testing. Does not actually connect or communicate with EV3 brick.
Public class | Port | An input or output port on the EV3 brick
Public class | ReportReceivedEventArgs | Event arguments for the ReportReceived event.
Public class | SystemCommand | Direct commands for the EV3 brick
Interfaces
 | Interface | Description
Public interface | ICommunication | Interface for communicating with the EV3 brick
Enumerations
 | Enumeration | Description
Public enumeration | BrickButton | Buttons on the face of the EV3 brick
Public enumeration | Color | UI colors
Public enumeration | ColorMode | EV3 Color Sensor mode
Public enumeration | ColorSensorColor | Values returned by the color sensor
Public enumeration | CommandType | The type of command being sent to the brick
Public enumeration | DeviceType | List of devices which can be recognized as input or output devices
Public enumeration | FontType | Font types for drawing text to the screen
Public enumeration | Format | Format for sensor data.
Public enumeration | GyroscopeMode | EV3 Gyroscope Sensor mode
Public enumeration | InfraredMode | EV3 Infrared Sensor mode
Public enumeration | InputPort | Ports which can receive input data
Public enumeration | LedPattern | Pattern to light up the EV3 brick's LED
Public enumeration | MotorMode | Motor mode
Public enumeration | NxtColorMode | NXT Color Sensor mode
Public enumeration | NxtLightMode | NXT Light Sensor mode
Public enumeration | NxtSoundMode | NXT Sound Sensor mode
Public enumeration | NxtTemperatureMode | NXT Temperature Sensor mode
Public enumeration | NxtUltrasonicMode | NXT Ultrasonic Sensor mode
Public enumeration | OutputPort | Ports which can send output
Public enumeration | Polarity | Polarity/direction to turn the motor
Public enumeration | TouchMode | NXT and EV3 Touch Sensor mode
Public enumeration | UltrasonicMode | EV3 Ultrasonic Sensor mode

For more information, please see the Online CodePlex project page and the Online Getting Started guide.


Brick Class

Brick Class LEGO Mindstorms EV3 API Documentation

Main EV3 brick interface
Inheritance Hierarchy
Online System Object
Lego.Ev3.Core Brick

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Brick
public sealed class Brick
Public NotInheritable Class Brick
Public NotInheritable Class Brick
public ref class Brick sealed
public ref class Brick sealed
See Also
Brick Members
Lego.Ev3.Core Namespace


Brick Members

Brick Members LEGO Mindstorms EV3 API Documentation

The Brick type exposes the following members.
Constructors
 | Name | Description
Public method | Brick(ICommunication) | Constructor
Public method | Brick(ICommunication, Boolean) | Constructor
Back to Top
Methods
 | Name | Description
Public method | ConnectAsync | Connect to the EV3 brick.
Public method | ConnectAsync(TimeSpan) | Connect to the EV3 brick with a specified polling time.
Public method | Disconnect | Disconnect from the EV3 brick
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | BatchCommand | Send a batch command of multiple direct commands at once. Call the Initialize(CommandType) method with the proper CommandType to set the type of command the batch should be executed as.
Public property | Buttons | Buttons on the face of the LEGO EV3 brick
Public property | DirectCommand | Send "direct commands" to the EV3 brick. These commands are executed instantly and are not batched.
Public property | LcdHeight | Height of LCD screen
Public property | LcdWidth | Width of LCD screen
Public property | Ports | Input and output ports on LEGO EV3 brick
Public property | SystemCommand | Send "system commands" to the EV3 brick. These commands are executed instantly and are not batched.
Public property | TopLineHeight | Height of status bar
Back to Top
Events
 | Name | Description
Public event | BrickChanged | Event that is fired when a port is changed
Back to Top
See Also
Brick Class


Brick Constructor

Brick Constructor LEGO Mindstorms EV3 API Documentation

Overload List
 | Name | Description
Public method | Brick(ICommunication) | Constructor
Public method | Brick(ICommunication, Boolean) | Constructor
Back to Top
See Also
Brick Class
Brick Members


Brick Constructor (ICommunication)

Brick Constructor (ICommunication) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Constructor

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Brick(
    ICommunication comm
)
public Brick(
    ICommunication comm
)
Public Sub New (
    comm As ICommunication
)
Public Sub New (
    comm As ICommunication
)
public:
Brick(
    ICommunication^ comm
)
public:
Brick(
    ICommunication^ comm
)
Parameters
comm
Type: Lego.Ev3.Core ICommunication
Object implementing the ICommunication interface for talking to the brick
See Also
Brick Class
Brick Members
Brick Overload


Brick Constructor (ICommunication, Boolean)

Brick Constructor (ICommunication, Boolean) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Constructor

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Brick(
    ICommunication comm,
    bool alwaysSendEvents
)
public Brick(
    ICommunication comm,
    bool alwaysSendEvents
)
Public Sub New (
    comm As ICommunication,
    alwaysSendEvents As Boolean
)
Public Sub New (
    comm As ICommunication,
    alwaysSendEvents As Boolean
)
public:
Brick(
    ICommunication^ comm,
    bool alwaysSendEvents
)
public:
Brick(
    ICommunication^ comm,
    bool alwaysSendEvents
)
Parameters
comm
Type: Lego.Ev3.Core ICommunication
Object implementing the ICommunication interface for talking to the brick
alwaysSendEvents
Type:   Online System Boolean
Send events when data changes, or at every poll
See Also
Brick Class
Brick Members
Brick Overload


Brick Methods

Brick Methods LEGO Mindstorms EV3 API Documentation

The Brick type exposes the following members.
Methods
 | Name | Description
Public method | ConnectAsync | Connect to the EV3 brick.
Public method | ConnectAsync(TimeSpan) | Connect to the EV3 brick with a specified polling time.
Public method | Disconnect | Disconnect from the EV3 brick
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
Brick Class


Brick.ConnectAsync Method

Brick ConnectAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Overload List
 | Name | Description
Public method | ConnectAsync | Connect to the EV3 brick.
Public method | ConnectAsync(TimeSpan) | Connect to the EV3 brick with a specified polling time.
Back to Top
See Also
Brick Class
Brick Members


Brick.ConnectAsync Method

Brick ConnectAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Connect to the EV3 brick.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task ConnectAsync()
public Task ConnectAsync()
Public Function ConnectAsync As Task
Public Function ConnectAsync As Task
public:
Task^ ConnectAsync()
public:
Task^ ConnectAsync()
Return Value
Type:   Online Task
See Also
Brick Class
Brick Members
ConnectAsync Overload


Brick.ConnectAsync Method (TimeSpan)

Brick ConnectAsync Method (TimeSpan) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Connect to the EV3 brick with a specified polling time.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task ConnectAsync(
    TimeSpan pollingTime
)
public Task ConnectAsync(
    TimeSpan pollingTime
)
Public Function ConnectAsync (
    pollingTime As TimeSpan
) As Task
Public Function ConnectAsync (
    pollingTime As TimeSpan
) As Task
public:
Task^ ConnectAsync(
    TimeSpan pollingTime
)
public:
Task^ ConnectAsync(
    TimeSpan pollingTime
)
Parameters
pollingTime
Type:   Online System TimeSpan
The period to poll the device status.  Set to TimeSpan.Zero to disable polling.
Return Value
Type:   Online Task
See Also
Brick Class
Brick Members
ConnectAsync Overload


Brick.Disconnect Method

Brick Disconnect Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Disconnect from the EV3 brick

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Disconnect()
public void Disconnect()
Public Sub Disconnect
Public Sub Disconnect
public:
void Disconnect()
public:
void Disconnect()
See Also
Brick Class
Brick Members


Brick Properties

Brick Properties LEGO Mindstorms EV3 API Documentation

The Brick type exposes the following members.
Properties
 | Name | Description
Public property | BatchCommand | Send a batch command of multiple direct commands at once. Call the Initialize(CommandType) method with the proper CommandType to set the type of command the batch should be executed as.
Public property | Buttons | Buttons on the face of the LEGO EV3 brick
Public property | DirectCommand | Send "direct commands" to the EV3 brick. These commands are executed instantly and are not batched.
Public property | LcdHeight | Height of LCD screen
Public property | LcdWidth | Width of LCD screen
Public property | Ports | Input and output ports on LEGO EV3 brick
Public property | SystemCommand | Send "system commands" to the EV3 brick. These commands are executed instantly and are not batched.
Public property | TopLineHeight | Height of status bar
Back to Top
See Also
Brick Class


Brick.BatchCommand Property

Brick BatchCommand Property LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Send a batch command of multiple direct commands at once. Call the Initialize(CommandType) method with the proper CommandType to set the type of command the batch should be executed as.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Command BatchCommand { get; }
public Command BatchCommand { get; }
Public ReadOnly Property BatchCommand As Command
    Get
Public ReadOnly Property BatchCommand As Command
    Get
public:
property Command^ BatchCommand {
    Command^ get ();
}
public:
property Command^ BatchCommand {
    Command^ get ();
}
Property Value
Type: Command
See Also
Brick Class
Brick Members


Brick.Buttons Property

Brick Buttons Property LEGO Mindstorms EV3 API Documentation

Buttons on the face of the LEGO EV3 brick

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BrickButtons Buttons { get; set; }
public BrickButtons Buttons { get; set; }
Public Property Buttons As BrickButtons
    Get
    Set
Public Property Buttons As BrickButtons
    Get
    Set
public:
property BrickButtons^ Buttons {
    BrickButtons^ get ();
    void set (BrickButtons^ value);
}
public:
property BrickButtons^ Buttons {
    BrickButtons^ get ();
    void set (BrickButtons^ value);
}
Property Value
Type: BrickButtons
See Also
Brick Class
Brick Members


Brick.DirectCommand Property

Brick DirectCommand Property LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Send "direct commands" to the EV3 brick. These commands are executed instantly and are not batched.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DirectCommand DirectCommand { get; }
public DirectCommand DirectCommand { get; }
Public ReadOnly Property DirectCommand As DirectCommand
    Get
Public ReadOnly Property DirectCommand As DirectCommand
    Get
public:
property DirectCommand^ DirectCommand {
    DirectCommand^ get ();
}
public:
property DirectCommand^ DirectCommand {
    DirectCommand^ get ();
}
Property Value
Type: DirectCommand
See Also
Brick Class
Brick Members


Brick.LcdHeight Property

Brick LcdHeight Property LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Height of LCD screen

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ushort LcdHeight { get; }
public ushort LcdHeight { get; }
Public ReadOnly Property LcdHeight As UShort
    Get
Public ReadOnly Property LcdHeight As UShort
    Get
public:
property unsigned short LcdHeight {
    unsigned short get ();
}
public:
property unsigned short LcdHeight {
    unsigned short get ();
}
Property Value
Type:   Online UInt16
See Also
Brick Class
Brick Members


Brick.LcdWidth Property

Brick LcdWidth Property LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Width of LCD screen

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ushort LcdWidth { get; }
public ushort LcdWidth { get; }
Public ReadOnly Property LcdWidth As UShort
    Get
Public ReadOnly Property LcdWidth As UShort
    Get
public:
property unsigned short LcdWidth {
    unsigned short get ();
}
public:
property unsigned short LcdWidth {
    unsigned short get ();
}
Property Value
Type:   Online UInt16
See Also
Brick Class
Brick Members


Brick.Ports Property

Brick Ports Property LEGO Mindstorms EV3 API Documentation

Input and output ports on LEGO EV3 brick

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<InputPort, Port> Ports { get; set; }
public IDictionary<InputPort, Port> Ports { get; set; }
Public Property Ports As IDictionary(Of InputPort, Port)
    Get
    Set
Public Property Ports As IDictionary(Of InputPort, Port)
    Get
    Set
public:
property IDictionary<InputPort, Port^>^ Ports {
    IDictionary<InputPort, Port^>^ get ();
    void set (IDictionary<InputPort, Port^>^ value);
}
public:
property IDictionary<InputPort, Port^>^ Ports {
    IDictionary<InputPort, Port^>^ get ();
    void set (IDictionary<InputPort, Port^>^ value);
}
Property Value
Type:   Online IDictionary  InputPort, Port
See Also
Brick Class
Brick Members


Brick.SystemCommand Property

Brick SystemCommand Property LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Send "system commands" to the EV3 brick. These commands are executed instantly and are not batched.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SystemCommand SystemCommand { get; }
public SystemCommand SystemCommand { get; }
Public ReadOnly Property SystemCommand As SystemCommand
    Get
Public ReadOnly Property SystemCommand As SystemCommand
    Get
public:
property SystemCommand^ SystemCommand {
    SystemCommand^ get ();
}
public:
property SystemCommand^ SystemCommand {
    SystemCommand^ get ();
}
Property Value
Type: SystemCommand
See Also
Brick Class
Brick Members


Brick.TopLineHeight Property

Brick TopLineHeight Property LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Height of status bar

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ushort TopLineHeight { get; }
public ushort TopLineHeight { get; }
Public ReadOnly Property TopLineHeight As UShort
    Get
Public ReadOnly Property TopLineHeight As UShort
    Get
public:
property unsigned short TopLineHeight {
    unsigned short get ();
}
public:
property unsigned short TopLineHeight {
    unsigned short get ();
}
Property Value
Type:   Online UInt16
See Also
Brick Class
Brick Members


Brick Events

Brick Events LEGO Mindstorms EV3 API Documentation

The Brick type exposes the following members.
Events
 | Name | Description
Public event | BrickChanged | Event that is fired when a port is changed
Back to Top
See Also
Brick Class


Brick.BrickChanged Event

Brick BrickChanged Event LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Event that is fired when a port is changed

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<BrickChangedEventArgs> BrickChanged
public event EventHandler<BrickChangedEventArgs> BrickChanged
Public Event BrickChanged As EventHandler(Of BrickChangedEventArgs)
Public Event BrickChanged As EventHandler(Of BrickChangedEventArgs)
public:
 event EventHandler<BrickChangedEventArgs^>^ BrickChanged {
    void add (EventHandler<BrickChangedEventArgs^>^ value);
    void remove (EventHandler<BrickChangedEventArgs^>^ value);
}
public:
 event EventHandler<BrickChangedEventArgs^>^ BrickChanged {
    void add (EventHandler<BrickChangedEventArgs^>^ value);
    void remove (EventHandler<BrickChangedEventArgs^>^ value);
}
Value
Type:   Online System EventHandler  BrickChangedEventArgs
See Also
Brick Class
Brick Members


BrickButton Enumeration

BrickButton Enumeration LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Buttons on the face of the EV3 brick

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum BrickButton
public enum BrickButton
Public Enumeration BrickButton
Public Enumeration BrickButton
public enum class BrickButton
public enum class BrickButton
Members
Member name | Value | Description
None | 0 | No button
Up | 1 | Up button
Enter | 2 | Enter button
Down | 3 | Down button
Right | 4 | Right button
Left | 5 | Left button
Back | 6 | Back button
Any | 7 | Any button
See Also


BrickButtons Class

BrickButtons Class LEGO Mindstorms EV3 API Documentation

Buttons on the face of the LEGO EV3 brick
Inheritance Hierarchy
Online System Object
Lego.Ev3.Core BrickButtons

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BrickButtons
public sealed class BrickButtons
Public NotInheritable Class BrickButtons
Public NotInheritable Class BrickButtons
public ref class BrickButtons sealed
public ref class BrickButtons sealed
See Also
BrickButtons Members


BrickButtons Members

BrickButtons Members LEGO Mindstorms EV3 API Documentation

The BrickButtons type exposes the following members.
Constructors
 | Name | Description
Public method | BrickButtons | Initializes a new instance of the BrickButtons class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Back | Back button
Public property | Down | Down button
Public property | Enter | Enter button
Public property | Left | Left button
Public property | Right | Right button
Public property | Up | Up button
Back to Top
See Also
BrickButtons Class


BrickButtons Constructor

BrickButtons Constructor LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Initializes a new instance of the BrickButtons class

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BrickButtons()
public BrickButtons()
Public Sub New
Public Sub New
public:
BrickButtons()
public:
BrickButtons()
See Also
BrickButtons Class
BrickButtons Members


BrickButtons Methods

BrickButtons Methods LEGO Mindstorms EV3 API Documentation

The BrickButtons type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
BrickButtons Class


BrickButtons Properties

BrickButtons Properties LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

The BrickButtons type exposes the following members.
Properties
 | Name | Description
Public property | Back | Back button
Public property | Down | Down button
Public property | Enter | Enter button
Public property | Left | Left button
Public property | Right | Right button
Public property | Up | Up button
Back to Top
See Also
BrickButtons Class


BrickButtons.Back Property

BrickButtons Back Property LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Back button

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Back { get; set; }
public bool Back { get; set; }
Public Property Back As Boolean
    Get
    Set
Public Property Back As Boolean
    Get
    Set
public:
property bool Back {
    bool get ();
    void set (bool value);
}
public:
property bool Back {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
See Also
BrickButtons Class
BrickButtons Members


BrickButtons.Down Property

BrickButtons Down Property LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Down button

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Down { get; set; }
public bool Down { get; set; }
Public Property Down As Boolean
    Get
    Set
Public Property Down As Boolean
    Get
    Set
public:
property bool Down {
    bool get ();
    void set (bool value);
}
public:
property bool Down {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
See Also
BrickButtons Class
BrickButtons Members


BrickButtons.Enter Property

BrickButtons Enter Property LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Enter button

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Enter { get; set; }
public bool Enter { get; set; }
Public Property Enter As Boolean
    Get
    Set
Public Property Enter As Boolean
    Get
    Set
public:
property bool Enter {
    bool get ();
    void set (bool value);
}
public:
property bool Enter {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
See Also
BrickButtons Class
BrickButtons Members


BrickButtons.Left Property

BrickButtons Left Property LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Left button

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Left { get; set; }
public bool Left { get; set; }
Public Property Left As Boolean
    Get
    Set
Public Property Left As Boolean
    Get
    Set
public:
property bool Left {
    bool get ();
    void set (bool value);
}
public:
property bool Left {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
See Also
BrickButtons Class
BrickButtons Members


BrickButtons.Right Property

BrickButtons Right Property LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Right button

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Right { get; set; }
public bool Right { get; set; }
Public Property Right As Boolean
    Get
    Set
Public Property Right As Boolean
    Get
    Set
public:
property bool Right {
    bool get ();
    void set (bool value);
}
public:
property bool Right {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
See Also
BrickButtons Class
BrickButtons Members


BrickButtons.Up Property

BrickButtons Up Property LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Up button

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Up { get; set; }
public bool Up { get; set; }
Public Property Up As Boolean
    Get
    Set
Public Property Up As Boolean
    Get
    Set
public:
property bool Up {
    bool get ();
    void set (bool value);
}
public:
property bool Up {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
See Also
BrickButtons Class
BrickButtons Members


BrickChangedEventArgs Class

BrickChangedEventArgs Class LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Arguments for PortsChanged event
Inheritance Hierarchy
Online System Object
Online System EventArgs
Lego.Ev3.Core BrickChangedEventArgs

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BrickChangedEventArgs : EventArgs
public sealed class BrickChangedEventArgs : EventArgs
Public NotInheritable Class BrickChangedEventArgs
    Inherits EventArgs
Public NotInheritable Class BrickChangedEventArgs
    Inherits EventArgs
public ref class BrickChangedEventArgs sealed : public EventArgs
public ref class BrickChangedEventArgs sealed : public EventArgs
See Also
BrickChangedEventArgs Members


BrickChangedEventArgs Members

BrickChangedEventArgs Members LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

The BrickChangedEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | BrickChangedEventArgs | Initializes a new instance of the BrickChangedEventArgs class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Buttons | Buttons on the face of the LEGO EV3 brick
Public property | Ports | A map of all ports on the EV3 brick
Back to Top
See Also
BrickChangedEventArgs Class


BrickChangedEventArgs Constructor

BrickChangedEventArgs Constructor LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Initializes a new instance of the BrickChangedEventArgs class

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BrickChangedEventArgs()
public BrickChangedEventArgs()
Public Sub New
Public Sub New
public:
BrickChangedEventArgs()
public:
BrickChangedEventArgs()
See Also
BrickChangedEventArgs Class
BrickChangedEventArgs Members


BrickChangedEventArgs Methods

BrickChangedEventArgs Methods LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

The BrickChangedEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
BrickChangedEventArgs Class


BrickChangedEventArgs Properties

BrickChangedEventArgs Properties LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

The BrickChangedEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Buttons | Buttons on the face of the LEGO EV3 brick
Public property | Ports | A map of all ports on the EV3 brick
Back to Top
See Also
BrickChangedEventArgs Class


BrickChangedEventArgs.Buttons Property

BrickChangedEventArgs Buttons Property LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Buttons on the face of the LEGO EV3 brick

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BrickButtons Buttons { get; set; }
public BrickButtons Buttons { get; set; }
Public Property Buttons As BrickButtons
    Get
    Set
Public Property Buttons As BrickButtons
    Get
    Set
public:
property BrickButtons^ Buttons {
    BrickButtons^ get ();
    void set (BrickButtons^ value);
}
public:
property BrickButtons^ Buttons {
    BrickButtons^ get ();
    void set (BrickButtons^ value);
}
Property Value
Type: BrickButtons
See Also
BrickChangedEventArgs Class
BrickChangedEventArgs Members


BrickChangedEventArgs.Ports Property

BrickChangedEventArgs Ports Property LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

A map of all ports on the EV3 brick

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<InputPort, Port> Ports { get; set; }
public IDictionary<InputPort, Port> Ports { get; set; }
Public Property Ports As IDictionary(Of InputPort, Port)
    Get
    Set
Public Property Ports As IDictionary(Of InputPort, Port)
    Get
    Set
public:
property IDictionary<InputPort, Port^>^ Ports {
    IDictionary<InputPort, Port^>^ get ();
    void set (IDictionary<InputPort, Port^>^ value);
}
public:
property IDictionary<InputPort, Port^>^ Ports {
    IDictionary<InputPort, Port^>^ get ();
    void set (IDictionary<InputPort, Port^>^ value);
}
Property Value
Type:   Online IDictionary  InputPort, Port
See Also
BrickChangedEventArgs Class
BrickChangedEventArgs Members


Color Enumeration

Color Enumeration LEGO Mindstorms EV3 API Documentation

UI colors

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum Color
public enum Color
Public Enumeration Color
Public Enumeration Color
public enum class Color
public enum class Color
Members
Member name | Value | Description
Background | 0 | Color of the background
Foreground | 1 | Color of the foreground


ColorMode Enumeration

ColorMode Enumeration LEGO Mindstorms EV3 API Documentation

EV3 Color Sensor mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum ColorMode
public enum ColorMode
Public Enumeration ColorMode
Public Enumeration ColorMode
public enum class ColorMode
public enum class ColorMode
Members
Member name | Value | Description
Reflective | 0 | Reflected color
Ambient | 1 | Ambient color
Color | 2 | Specific color
ReflectiveRaw | 3 | Reflected color raw value
ReflectiveRgb | 4 | Reflected color RGB value
Calibration | 5 | Calibration


ColorSensorColor Enumeration

ColorSensorColor Enumeration LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Values returned by the color sensor

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum ColorSensorColor
public enum ColorSensorColor
Public Enumeration ColorSensorColor
Public Enumeration ColorSensorColor
public enum class ColorSensorColor
public enum class ColorSensorColor
Members
Member name | Value | Description
Transparent | 0 | Transparent
Black | 1 | Black
Blue | 2 | Blue
Green | 3 | Green
Yellow | 4 | Yellow
Red | 5 | Red
White | 6 | White
Brown | 7 | Brown


Command Class

Command Class LEGO Mindstorms EV3 API Documentation

Command or chain of commands to be written to the EV3 brick
Inheritance Hierarchy
Online System Object
Lego.Ev3.Core Command

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Command
public sealed class Command
Public NotInheritable Class Command
Public NotInheritable Class Command
public ref class Command sealed
public ref class Command sealed
See Also
Command Members


Command Members

Command Members LEGO Mindstorms EV3 API Documentation

The Command type exposes the following members.
Methods
 | Name | Description
Public method | CleanUI | Append the Clean UI command to an existing Command object
Public method | ClearAllDevices | Append the Clear All Devices command to an existing Command object
Public method | ClearChanges | Append the Clear Changes command to an existing Command object
Public method | CreateDirectory | Append the Create Directory command to an existing Command object
Public method | DeleteFile | Append the Delete File command to an existing Command object
Public method | DrawCircle | Append the Draw Circle command to an existing Command object
Public method | DrawDottedLine | Append the Draw Dotted Line command to an existing Command object
Public method | DrawFillWindow | Append the Draw Fill Window command to an existing Command object
Public method | DrawImage | Append the Draw Image command to an existing Command object
Public method | DrawInverseRectangle | Append the Draw Inverse Rectangle command to an existing Command object
Public method | DrawLine | Append the Draw Line command to an existing Command object
Public method | DrawPixel | Append the Draw Pixel command to an existing Command object
Public method | DrawRectangle | Append the Draw Rectangle command to an existing Command object
Public method | DrawText | Append the Draw Text command to an existing Command object
Public method | EnableTopLine | Append the Enable Top Line command to an existing Command object
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDeviceName | Append the Get Device Name command to an existing Command object
Public method | GetFirwmareVersion | Append the Get Firmware Version command to an existing Command object
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetModeName | Append the Get Mode Name command to an existing Command object
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeMode | Append the Get Type/Mode command to an existing Command object
Public method | Initialize(CommandType) | Start a new command of a specific type
Public method | Initialize(CommandType, UInt16, Int32) | Start a new command of a speicifc type with a global and/or local buffer on the EV3 brick
Public method | IsBrickButtonPressed | Add the Is Brick Pressed command to an existing Command object
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PlaySound | Append the Play Sound command to an existing Command object
Public method | PlayTone | Append the Play Tone command to an existing Command object
Public method | ReadyPercent | Append the Ready Percent command to an existing Command object
Public method | ReadyRaw | Append the Ready Raw command to an existing Command object
Public method | ReadySI | Append the Ready SI command to an existing Command object
Public method | SelectFont | Append the Select Font command to an existing Command object
Public method | SendCommandAsync | End and send a Command to the EV3 brick.
Public method | SetLedPattern | Append the Set LED Pattern command to an existing Command object
Public method | SetMotorPolarity | Append the Set Polarity command to an existing Command object
Public method | StartMotor | Start the motor(s) based on previous commands
Public method | StepMotorAtPower(OutputPort, Int32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified power for the specified number of steps.
Public method | StepMotorAtPower(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified power for the specified number of steps.
Public method | StepMotorAtSpeed(OutputPort, Int32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified speed for the specified number of steps.
Public method | StepMotorAtSpeed(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified speed for the specified number of steps.
Public method | StepMotorSync | Synchronize stepping of motors.
Public method | StopMotor | Append the Stop Motor command to an existing Command object
Public method | TimeMotorSync | Synchronize timing of motors.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TurnMotorAtPower | Turns the specified motor at the specified power
Public method | TurnMotorAtPowerForTime(OutputPort, Int32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified power for the specified times.
Public method | TurnMotorAtPowerForTime(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified power for the specified times.
Public method | TurnMotorAtSpeed | Turn the specified motor at the specified speed.
Public method | TurnMotorAtSpeedForTime(OutputPort, Int32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified speed for the specified times.
Public method | TurnMotorAtSpeedForTime(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified speed for the specified times.
Public method | UpdateUI | Append the Update UI command to an existing Command object
Back to Top
See Also
Command Class


Command Methods

Command Methods LEGO Mindstorms EV3 API Documentation

The Command type exposes the following members.
Methods
 | Name | Description
Public method | CleanUI | Append the Clean UI command to an existing Command object
Public method | ClearAllDevices | Append the Clear All Devices command to an existing Command object
Public method | ClearChanges | Append the Clear Changes command to an existing Command object
Public method | CreateDirectory | Append the Create Directory command to an existing Command object
Public method | DeleteFile | Append the Delete File command to an existing Command object
Public method | DrawCircle | Append the Draw Circle command to an existing Command object
Public method | DrawDottedLine | Append the Draw Dotted Line command to an existing Command object
Public method | DrawFillWindow | Append the Draw Fill Window command to an existing Command object
Public method | DrawImage | Append the Draw Image command to an existing Command object
Public method | DrawInverseRectangle | Append the Draw Inverse Rectangle command to an existing Command object
Public method | DrawLine | Append the Draw Line command to an existing Command object
Public method | DrawPixel | Append the Draw Pixel command to an existing Command object
Public method | DrawRectangle | Append the Draw Rectangle command to an existing Command object
Public method | DrawText | Append the Draw Text command to an existing Command object
Public method | EnableTopLine | Append the Enable Top Line command to an existing Command object
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDeviceName | Append the Get Device Name command to an existing Command object
Public method | GetFirwmareVersion | Append the Get Firmware Version command to an existing Command object
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetModeName | Append the Get Mode Name command to an existing Command object
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeMode | Append the Get Type/Mode command to an existing Command object
Public method | Initialize(CommandType) | Start a new command of a specific type
Public method | Initialize(CommandType, UInt16, Int32) | Start a new command of a speicifc type with a global and/or local buffer on the EV3 brick
Public method | IsBrickButtonPressed | Add the Is Brick Pressed command to an existing Command object
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PlaySound | Append the Play Sound command to an existing Command object
Public method | PlayTone | Append the Play Tone command to an existing Command object
Public method | ReadyPercent | Append the Ready Percent command to an existing Command object
Public method | ReadyRaw | Append the Ready Raw command to an existing Command object
Public method | ReadySI | Append the Ready SI command to an existing Command object
Public method | SelectFont | Append the Select Font command to an existing Command object
Public method | SendCommandAsync | End and send a Command to the EV3 brick.
Public method | SetLedPattern | Append the Set LED Pattern command to an existing Command object
Public method | SetMotorPolarity | Append the Set Polarity command to an existing Command object
Public method | StartMotor | Start the motor(s) based on previous commands
Public method | StepMotorAtPower(OutputPort, Int32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified power for the specified number of steps.
Public method | StepMotorAtPower(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified power for the specified number of steps.
Public method | StepMotorAtSpeed(OutputPort, Int32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified speed for the specified number of steps.
Public method | StepMotorAtSpeed(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified speed for the specified number of steps.
Public method | StepMotorSync | Synchronize stepping of motors.
Public method | StopMotor | Append the Stop Motor command to an existing Command object
Public method | TimeMotorSync | Synchronize timing of motors.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TurnMotorAtPower | Turns the specified motor at the specified power
Public method | TurnMotorAtPowerForTime(OutputPort, Int32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified power for the specified times.
Public method | TurnMotorAtPowerForTime(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified power for the specified times.
Public method | TurnMotorAtSpeed | Turn the specified motor at the specified speed.
Public method | TurnMotorAtSpeedForTime(OutputPort, Int32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified speed for the specified times.
Public method | TurnMotorAtSpeedForTime(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified speed for the specified times.
Public method | UpdateUI | Append the Update UI command to an existing Command object
Back to Top
See Also
Command Class


Command.CleanUI Method

Command CleanUI Method LEGO Mindstorms EV3 API Documentation

Append the Clean UI command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CleanUI()
public void CleanUI()
Public Sub CleanUI
Public Sub CleanUI
public:
void CleanUI()
public:
void CleanUI()
See Also
Command Class
Command Members


Command.ClearAllDevices Method

Command ClearAllDevices Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Clear All Devices command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ClearAllDevices()
public void ClearAllDevices()
Public Sub ClearAllDevices
Public Sub ClearAllDevices
public:
void ClearAllDevices()
public:
void ClearAllDevices()
See Also
Command Class
Command Members


Command.ClearChanges Method

Command ClearChanges Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Clear Changes command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ClearChanges(
    InputPort port
)
public void ClearChanges(
    InputPort port
)
Public Sub ClearChanges (
    port As InputPort
)
Public Sub ClearChanges (
    port As InputPort
)
public:
void ClearChanges(
    InputPort port
)
public:
void ClearChanges(
    InputPort port
)
Parameters
port
Type: Lego.Ev3.Core InputPort
[Missing <param name="port"/> documentation for "M:Lego.Ev3.Core.Command.ClearChanges(Lego.Ev3.Core.InputPort)"]
See Also
Command Class
Command Members


Command.CreateDirectory Method

Command CreateDirectory Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Create Directory command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CreateDirectory(
    string devicePath
)
public void CreateDirectory(
    string devicePath
)
Public Sub CreateDirectory (
    devicePath As String
)
Public Sub CreateDirectory (
    devicePath As String
)
public:
void CreateDirectory(
    String^ devicePath
)
public:
void CreateDirectory(
    String^ devicePath
)
Parameters
devicePath
Type:   Online System String
Directory name on the brick to create
See Also
Command Class
Command Members


Command.DeleteFile Method

Command DeleteFile Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Delete File command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DeleteFile(
    string devicePath
)
public void DeleteFile(
    string devicePath
)
Public Sub DeleteFile (
    devicePath As String
)
Public Sub DeleteFile (
    devicePath As String
)
public:
void DeleteFile(
    String^ devicePath
)
public:
void DeleteFile(
    String^ devicePath
)
Parameters
devicePath
Type:   Online System String
Filename on the brick to delete
See Also
Command Class
Command Members


Command.DrawCircle Method

Command DrawCircle Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Draw Circle command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DrawCircle(
    Color color,
    ushort x,
    ushort y,
    ushort radius,
    bool filled
)
public void DrawCircle(
    Color color,
    ushort x,
    ushort y,
    ushort radius,
    bool filled
)
Public Sub DrawCircle (
    color As Color,
    x As UShort,
    y As UShort,
    radius As UShort,
    filled As Boolean
)
Public Sub DrawCircle (
    color As Color,
    x As UShort,
    y As UShort,
    radius As UShort,
    filled As Boolean
)
public:
void DrawCircle(
    Color color,
    unsigned short x,
    unsigned short y,
    unsigned short radius,
    bool filled
)
public:
void DrawCircle(
    Color color,
    unsigned short x,
    unsigned short y,
    unsigned short radius,
    bool filled
)
Parameters
color
Type: Lego.Ev3.Core Color
Color of the circle
x
Type:   Online System UInt16
X position
y
Type:   Online System UInt16
Y position
radius
Type:   Online System UInt16
Radius of circle
filled
Type:   Online System Boolean
Draw a filled or empty circle
See Also
Command Class
Command Members


Command.DrawDottedLine Method

Command DrawDottedLine Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Draw Dotted Line command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DrawDottedLine(
    Color color,
    ushort x0,
    ushort y0,
    ushort x1,
    ushort y1,
    ushort onPixels,
    ushort offPixels
)
public void DrawDottedLine(
    Color color,
    ushort x0,
    ushort y0,
    ushort x1,
    ushort y1,
    ushort onPixels,
    ushort offPixels
)
Public Sub DrawDottedLine (
    color As Color,
    x0 As UShort,
    y0 As UShort,
    x1 As UShort,
    y1 As UShort,
    onPixels As UShort,
    offPixels As UShort
)
Public Sub DrawDottedLine (
    color As Color,
    x0 As UShort,
    y0 As UShort,
    x1 As UShort,
    y1 As UShort,
    onPixels As UShort,
    offPixels As UShort
)
public:
void DrawDottedLine(
    Color color,
    unsigned short x0,
    unsigned short y0,
    unsigned short x1,
    unsigned short y1,
    unsigned short onPixels,
    unsigned short offPixels
)
public:
void DrawDottedLine(
    Color color,
    unsigned short x0,
    unsigned short y0,
    unsigned short x1,
    unsigned short y1,
    unsigned short onPixels,
    unsigned short offPixels
)
Parameters
color
Type: Lego.Ev3.Core Color
The color of the line
x0
Type:   Online System UInt16
X start
y0
Type:   Online System UInt16
Y start
x1
Type:   Online System UInt16
X end
y1
Type:   Online System UInt16
Y end
onPixels
Type:   Online System UInt16
Number of pixels the line is on
offPixels
Type:   Online System UInt16
Number of pixels the line is off
See Also
Command Class
Command Members


Command.DrawFillWindow Method

Command DrawFillWindow Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Draw Fill Window command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DrawFillWindow(
    Color color,
    ushort y0,
    ushort y1
)
public void DrawFillWindow(
    Color color,
    ushort y0,
    ushort y1
)
Public Sub DrawFillWindow (
    color As Color,
    y0 As UShort,
    y1 As UShort
)
Public Sub DrawFillWindow (
    color As Color,
    y0 As UShort,
    y1 As UShort
)
public:
void DrawFillWindow(
    Color color,
    unsigned short y0,
    unsigned short y1
)
public:
void DrawFillWindow(
    Color color,
    unsigned short y0,
    unsigned short y1
)
Parameters
color
Type: Lego.Ev3.Core Color
The color to fill
y0
Type:   Online System UInt16
Y start
y1
Type:   Online System UInt16
Y end
See Also
Command Class
Command Members


Command.DrawImage Method

Command DrawImage Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Draw Image command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DrawImage(
    Color color,
    ushort x,
    ushort y,
    string devicePath
)
public void DrawImage(
    Color color,
    ushort x,
    ushort y,
    string devicePath
)
Public Sub DrawImage (
    color As Color,
    x As UShort,
    y As UShort,
    devicePath As String
)
Public Sub DrawImage (
    color As Color,
    x As UShort,
    y As UShort,
    devicePath As String
)
public:
void DrawImage(
    Color color,
    unsigned short x,
    unsigned short y,
    String^ devicePath
)
public:
void DrawImage(
    Color color,
    unsigned short x,
    unsigned short y,
    String^ devicePath
)
Parameters
color
Type: Lego.Ev3.Core Color
The color of the image to draw
x
Type:   Online System UInt16
X position
y
Type:   Online System UInt16
Y position
devicePath
Type:   Online System String
Filename on the brick of the image to draw
See Also
Command Class
Command Members


Command.DrawInverseRectangle Method

Command DrawInverseRectangle Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Draw Inverse Rectangle command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DrawInverseRectangle(
    ushort x,
    ushort y,
    ushort width,
    ushort height
)
public void DrawInverseRectangle(
    ushort x,
    ushort y,
    ushort width,
    ushort height
)
Public Sub DrawInverseRectangle (
    x As UShort,
    y As UShort,
    width As UShort,
    height As UShort
)
Public Sub DrawInverseRectangle (
    x As UShort,
    y As UShort,
    width As UShort,
    height As UShort
)
public:
void DrawInverseRectangle(
    unsigned short x,
    unsigned short y,
    unsigned short width,
    unsigned short height
)
public:
void DrawInverseRectangle(
    unsigned short x,
    unsigned short y,
    unsigned short width,
    unsigned short height
)
Parameters
x
Type:   Online System UInt16
X position
y
Type:   Online System UInt16
Y position
width
Type:   Online System UInt16
Width of rectangle
height
Type:   Online System UInt16
Height of rectangle
See Also
Command Class
Command Members


Command.DrawLine Method

Command DrawLine Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Draw Line command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DrawLine(
    Color color,
    ushort x0,
    ushort y0,
    ushort x1,
    ushort y1
)
public void DrawLine(
    Color color,
    ushort x0,
    ushort y0,
    ushort x1,
    ushort y1
)
Public Sub DrawLine (
    color As Color,
    x0 As UShort,
    y0 As UShort,
    x1 As UShort,
    y1 As UShort
)
Public Sub DrawLine (
    color As Color,
    x0 As UShort,
    y0 As UShort,
    x1 As UShort,
    y1 As UShort
)
public:
void DrawLine(
    Color color,
    unsigned short x0,
    unsigned short y0,
    unsigned short x1,
    unsigned short y1
)
public:
void DrawLine(
    Color color,
    unsigned short x0,
    unsigned short y0,
    unsigned short x1,
    unsigned short y1
)
Parameters
color
Type: Lego.Ev3.Core Color
Color of the line
x0
Type:   Online System UInt16
X start
y0
Type:   Online System UInt16
Y start
x1
Type:   Online System UInt16
X end
y1
Type:   Online System UInt16
Y end
See Also
Command Class
Command Members


Command.DrawPixel Method

Command DrawPixel Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Draw Pixel command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DrawPixel(
    Color color,
    ushort x,
    ushort y
)
public void DrawPixel(
    Color color,
    ushort x,
    ushort y
)
Public Sub DrawPixel (
    color As Color,
    x As UShort,
    y As UShort
)
Public Sub DrawPixel (
    color As Color,
    x As UShort,
    y As UShort
)
public:
void DrawPixel(
    Color color,
    unsigned short x,
    unsigned short y
)
public:
void DrawPixel(
    Color color,
    unsigned short x,
    unsigned short y
)
Parameters
color
Type: Lego.Ev3.Core Color
Color of the pixel
x
Type:   Online System UInt16
X position
y
Type:   Online System UInt16
Y position
See Also
Command Class
Command Members


Command.DrawRectangle Method

Command DrawRectangle Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Draw Rectangle command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DrawRectangle(
    Color color,
    ushort x,
    ushort y,
    ushort width,
    ushort height,
    bool filled
)
public void DrawRectangle(
    Color color,
    ushort x,
    ushort y,
    ushort width,
    ushort height,
    bool filled
)
Public Sub DrawRectangle (
    color As Color,
    x As UShort,
    y As UShort,
    width As UShort,
    height As UShort,
    filled As Boolean
)
Public Sub DrawRectangle (
    color As Color,
    x As UShort,
    y As UShort,
    width As UShort,
    height As UShort,
    filled As Boolean
)
public:
void DrawRectangle(
    Color color,
    unsigned short x,
    unsigned short y,
    unsigned short width,
    unsigned short height,
    bool filled
)
public:
void DrawRectangle(
    Color color,
    unsigned short x,
    unsigned short y,
    unsigned short width,
    unsigned short height,
    bool filled
)
Parameters
color
Type: Lego.Ev3.Core Color
Color of the rectangle
x
Type:   Online System UInt16
X position
y
Type:   Online System UInt16
Y position
width
Type:   Online System UInt16
Width of rectangle
height
Type:   Online System UInt16
Height of the rectangle
filled
Type:   Online System Boolean
Draw a filled or empty rectangle
See Also
Command Class
Command Members


Command.DrawText Method

Command DrawText Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Draw Text command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DrawText(
    Color color,
    ushort x,
    ushort y,
    string text
)
public void DrawText(
    Color color,
    ushort x,
    ushort y,
    string text
)
Public Sub DrawText (
    color As Color,
    x As UShort,
    y As UShort,
    text As String
)
Public Sub DrawText (
    color As Color,
    x As UShort,
    y As UShort,
    text As String
)
public:
void DrawText(
    Color color,
    unsigned short x,
    unsigned short y,
    String^ text
)
public:
void DrawText(
    Color color,
    unsigned short x,
    unsigned short y,
    String^ text
)
Parameters
color
Type: Lego.Ev3.Core Color
Color of the text
x
Type:   Online System UInt16
X position
y
Type:   Online System UInt16
Y position
text
Type:   Online System String
Text to draw
See Also
Command Class
Command Members


Command.EnableTopLine Method

Command EnableTopLine Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Enable Top Line command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void EnableTopLine(
    bool enabled
)
public void EnableTopLine(
    bool enabled
)
Public Sub EnableTopLine (
    enabled As Boolean
)
Public Sub EnableTopLine (
    enabled As Boolean
)
public:
void EnableTopLine(
    bool enabled
)
public:
void EnableTopLine(
    bool enabled
)
Parameters
enabled
Type:   Online System Boolean
Enable/disable the top status bar line
See Also
Command Class
Command Members


Command.GetDeviceName Method

Command GetDeviceName Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Get Device Name command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void GetDeviceName(
    InputPort port,
    int bufferSize,
    int index
)
public void GetDeviceName(
    InputPort port,
    int bufferSize,
    int index
)
Public Sub GetDeviceName (
    port As InputPort,
    bufferSize As Integer,
    index As Integer
)
Public Sub GetDeviceName (
    port As InputPort,
    bufferSize As Integer,
    index As Integer
)
public:
void GetDeviceName(
    InputPort port,
    int bufferSize,
    int index
)
public:
void GetDeviceName(
    InputPort port,
    int bufferSize,
    int index
)
Parameters
port
Type: Lego.Ev3.Core InputPort
The port to query
bufferSize
Type:   Online System Int32
Size of the buffer to hold the returned data
index
Type:   Online System Int32
Index to the position of the returned data in the global buffer
See Also
Command Class
Command Members


Command.GetFirwmareVersion Method

Command GetFirwmareVersion Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Get Firmware Version command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void GetFirwmareVersion(
    uint maxLength,
    uint index
)
public void GetFirwmareVersion(
    uint maxLength,
    uint index
)
Public Sub GetFirwmareVersion (
    maxLength As UInteger,
    index As UInteger
)
Public Sub GetFirwmareVersion (
    maxLength As UInteger,
    index As UInteger
)
public:
void GetFirwmareVersion(
    unsigned int maxLength,
    unsigned int index
)
public:
void GetFirwmareVersion(
    unsigned int maxLength,
    unsigned int index
)
Parameters
maxLength
Type:   Online System UInt32
Maximum length of string to be returned
index
Type:   Online System UInt32
Index at which the data should be returned inside of the global buffer
See Also
Command Class
Command Members


Command.GetModeName Method

Command GetModeName Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Get Mode Name command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void GetModeName(
    InputPort port,
    int mode,
    int bufferSize,
    int index
)
public void GetModeName(
    InputPort port,
    int mode,
    int bufferSize,
    int index
)
Public Sub GetModeName (
    port As InputPort,
    mode As Integer,
    bufferSize As Integer,
    index As Integer
)
Public Sub GetModeName (
    port As InputPort,
    mode As Integer,
    bufferSize As Integer,
    index As Integer
)
public:
void GetModeName(
    InputPort port,
    int mode,
    int bufferSize,
    int index
)
public:
void GetModeName(
    InputPort port,
    int mode,
    int bufferSize,
    int index
)
Parameters
port
Type: Lego.Ev3.Core InputPort
The port to query
mode
Type:   Online System Int32
The mode of the name to get
bufferSize
Type:   Online System Int32
Size of the buffer to hold the returned data
index
Type:   Online System Int32
Index to the position of the returned data in the global buffer
See Also
Command Class
Command Members


Command.GetTypeMode Method

Command GetTypeMode Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Get Type/Mode command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void GetTypeMode(
    InputPort port,
    uint typeIndex,
    uint modeIndex
)
public void GetTypeMode(
    InputPort port,
    uint typeIndex,
    uint modeIndex
)
Public Sub GetTypeMode (
    port As InputPort,
    typeIndex As UInteger,
    modeIndex As UInteger
)
Public Sub GetTypeMode (
    port As InputPort,
    typeIndex As UInteger,
    modeIndex As UInteger
)
public:
void GetTypeMode(
    InputPort port,
    unsigned int typeIndex,
    unsigned int modeIndex
)
public:
void GetTypeMode(
    InputPort port,
    unsigned int typeIndex,
    unsigned int modeIndex
)
Parameters
port
Type: Lego.Ev3.Core InputPort
The port to query
typeIndex
Type:   Online System UInt32
The index to hold the Type value in the global buffer
modeIndex
Type:   Online System UInt32
The index to hold the Mode value in the global buffer
See Also
Command Class
Command Members


Command.Initialize Method

Command Initialize Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Overload List
 | Name | Description
Public method | Initialize(CommandType) | Start a new command of a specific type
Public method | Initialize(CommandType, UInt16, Int32) | Start a new command of a speicifc type with a global and/or local buffer on the EV3 brick
Back to Top
See Also
Command Class
Command Members


Command.Initialize Method (CommandType)

Command Initialize Method (CommandType) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Start a new command of a specific type

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Initialize(
    CommandType commandType
)
public void Initialize(
    CommandType commandType
)
Public Sub Initialize (
    commandType As CommandType
)
Public Sub Initialize (
    commandType As CommandType
)
public:
void Initialize(
    CommandType commandType
)
public:
void Initialize(
    CommandType commandType
)
Parameters
commandType
Type: Lego.Ev3.Core CommandType
The type of the command to start
See Also
Command Class
Command Members
Initialize Overload


Command.Initialize Method (CommandType, UInt16, Int32)

Command Initialize Method (CommandType, UInt16, Int32) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Start a new command of a speicifc type with a global and/or local buffer on the EV3 brick

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Initialize(
    CommandType commandType,
    ushort globalSize,
    int localSize
)
public void Initialize(
    CommandType commandType,
    ushort globalSize,
    int localSize
)
Public Sub Initialize (
    commandType As CommandType,
    globalSize As UShort,
    localSize As Integer
)
Public Sub Initialize (
    commandType As CommandType,
    globalSize As UShort,
    localSize As Integer
)
public:
void Initialize(
    CommandType commandType,
    unsigned short globalSize,
    int localSize
)
public:
void Initialize(
    CommandType commandType,
    unsigned short globalSize,
    int localSize
)
Parameters
commandType
Type: Lego.Ev3.Core CommandType
The type of the command to start
globalSize
Type:   Online System UInt16
The size of the global buffer in bytes (maximum of 1024 bytes)
localSize
Type:   Online System Int32
The size of the local buffer in bytes (maximum of 64 bytes)
See Also
Command Class
Command Members
Initialize Overload


Command.IsBrickButtonPressed Method

Command IsBrickButtonPressed Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Add the Is Brick Pressed command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void IsBrickButtonPressed(
    BrickButton button,
    int index
)
public void IsBrickButtonPressed(
    BrickButton button,
    int index
)
Public Sub IsBrickButtonPressed (
    button As BrickButton,
    index As Integer
)
Public Sub IsBrickButtonPressed (
    button As BrickButton,
    index As Integer
)
public:
void IsBrickButtonPressed(
    BrickButton button,
    int index
)
public:
void IsBrickButtonPressed(
    BrickButton button,
    int index
)
Parameters
button
Type: Lego.Ev3.Core BrickButton
Button to check
index
Type:   Online System Int32
Index at which the data should be returned inside of the global buffer
See Also
Command Class
Command Members


Command.PlaySound Method

Command PlaySound Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Play Sound command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void PlaySound(
    int volume,
    string filename
)
public void PlaySound(
    int volume,
    string filename
)
Public Sub PlaySound (
    volume As Integer,
    filename As String
)
Public Sub PlaySound (
    volume As Integer,
    filename As String
)
public:
void PlaySound(
    int volume,
    String^ filename
)
public:
void PlaySound(
    int volume,
    String^ filename
)
Parameters
volume
Type:   Online System Int32
Volume to play the sound
filename
Type:   Online System String
Filename on the Brick of the sound to play
See Also
Command Class
Command Members


Command.PlayTone Method

Command PlayTone Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Play Tone command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void PlayTone(
    int volume,
    ushort frequency,
    ushort duration
)
public void PlayTone(
    int volume,
    ushort frequency,
    ushort duration
)
Public Sub PlayTone (
    volume As Integer,
    frequency As UShort,
    duration As UShort
)
Public Sub PlayTone (
    volume As Integer,
    frequency As UShort,
    duration As UShort
)
public:
void PlayTone(
    int volume,
    unsigned short frequency,
    unsigned short duration
)
public:
void PlayTone(
    int volume,
    unsigned short frequency,
    unsigned short duration
)
Parameters
volume
Type:   Online System Int32
Volme to play the tone (0-100)
frequency
Type:   Online System UInt16
Frequency of the tone in hertz
duration
Type:   Online System UInt16
Duration of the tone in milliseconds
See Also
Command Class
Command Members


Command.ReadyPercent Method

Command ReadyPercent Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Ready Percent command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ReadyPercent(
    InputPort port,
    int mode,
    int index
)
public void ReadyPercent(
    InputPort port,
    int mode,
    int index
)
Public Sub ReadyPercent (
    port As InputPort,
    mode As Integer,
    index As Integer
)
Public Sub ReadyPercent (
    port As InputPort,
    mode As Integer,
    index As Integer
)
public:
void ReadyPercent(
    InputPort port,
    int mode,
    int index
)
public:
void ReadyPercent(
    InputPort port,
    int mode,
    int index
)
Parameters
port
Type: Lego.Ev3.Core InputPort
The port to query
mode
Type:   Online System Int32
The mode to query the value as
index
Type:   Online System Int32
The index in the global buffer to hold the return value
See Also
Command Class
Command Members


Command.ReadyRaw Method

Command ReadyRaw Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Ready Raw command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ReadyRaw(
    InputPort port,
    int mode,
    int index
)
public void ReadyRaw(
    InputPort port,
    int mode,
    int index
)
Public Sub ReadyRaw (
    port As InputPort,
    mode As Integer,
    index As Integer
)
Public Sub ReadyRaw (
    port As InputPort,
    mode As Integer,
    index As Integer
)
public:
void ReadyRaw(
    InputPort port,
    int mode,
    int index
)
public:
void ReadyRaw(
    InputPort port,
    int mode,
    int index
)
Parameters
port
Type: Lego.Ev3.Core InputPort
The port to query
mode
Type:   Online System Int32
The mode to query the value as
index
Type:   Online System Int32
The index in the global buffer to hold the return value
See Also
Command Class
Command Members


Command.ReadySI Method

Command ReadySI Method LEGO Mindstorms EV3 API Documentation

Append the Ready SI command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ReadySI(
    InputPort port,
    int mode,
    int index
)
public void ReadySI(
    InputPort port,
    int mode,
    int index
)
Public Sub ReadySI (
    port As InputPort,
    mode As Integer,
    index As Integer
)
Public Sub ReadySI (
    port As InputPort,
    mode As Integer,
    index As Integer
)
public:
void ReadySI(
    InputPort port,
    int mode,
    int index
)
public:
void ReadySI(
    InputPort port,
    int mode,
    int index
)
Parameters
port
Type: Lego.Ev3.Core InputPort
The port to query
mode
Type:   Online System Int32
The mode to read the data as
index
Type:   Online System Int32
The index to hold the return value in the global buffer
See Also
Command Class
Command Members


Command.SelectFont Method

Command SelectFont Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Select Font command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SelectFont(
    FontType fontType
)
public void SelectFont(
    FontType fontType
)
Public Sub SelectFont (
    fontType As FontType
)
Public Sub SelectFont (
    fontType As FontType
)
public:
void SelectFont(
    FontType fontType
)
public:
void SelectFont(
    FontType fontType
)
Parameters
fontType
Type: Lego.Ev3.Core FontType
The font to select
See Also
Command Class
Command Members


Command.SendCommandAsync Method

Command SendCommandAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

End and send a Command to the EV3 brick.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<byte[]> SendCommandAsync()
public Task<byte[]> SendCommandAsync()
Public Function SendCommandAsync As Task(Of Byte())
Public Function SendCommandAsync As Task(Of Byte())
public:
Task<array<unsigned char>^>^ SendCommandAsync()
public:
Task<array<unsigned char>^>^ SendCommandAsync()
Return Value
Type:   Online Task     Online Byte
A byte array containing the response from the brick, if any.
See Also
Command Class
Command Members


Command.SetLedPattern Method

Command SetLedPattern Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Set LED Pattern command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetLedPattern(
    LedPattern ledPattern
)
public void SetLedPattern(
    LedPattern ledPattern
)
Public Sub SetLedPattern (
    ledPattern As LedPattern
)
Public Sub SetLedPattern (
    ledPattern As LedPattern
)
public:
void SetLedPattern(
    LedPattern ledPattern
)
public:
void SetLedPattern(
    LedPattern ledPattern
)
Parameters
ledPattern
Type: Lego.Ev3.Core LedPattern
The LED pattern to display
See Also
Command Class
Command Members


Command.SetMotorPolarity Method

Command SetMotorPolarity Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Set Polarity command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetMotorPolarity(
    OutputPort ports,
    Polarity polarity
)
public void SetMotorPolarity(
    OutputPort ports,
    Polarity polarity
)
Public Sub SetMotorPolarity (
    ports As OutputPort,
    polarity As Polarity
)
Public Sub SetMotorPolarity (
    ports As OutputPort,
    polarity As Polarity
)
public:
void SetMotorPolarity(
    OutputPort ports,
    Polarity polarity
)
public:
void SetMotorPolarity(
    OutputPort ports,
    Polarity polarity
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
Port or ports to change polarity
polarity
Type: Lego.Ev3.Core Polarity
The new polarity (direction) value
See Also
Command Class
Command Members


Command.StartMotor Method

Command StartMotor Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Start the motor(s) based on previous commands

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void StartMotor(
    OutputPort ports
)
public void StartMotor(
    OutputPort ports
)
Public Sub StartMotor (
    ports As OutputPort
)
Public Sub StartMotor (
    ports As OutputPort
)
public:
void StartMotor(
    OutputPort ports
)
public:
void StartMotor(
    OutputPort ports
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
Port or ports to apply the command to.
See Also
Command Class
Command Members


Command.StepMotorAtPower Method

Command StepMotorAtPower Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Overload List
 | Name | Description
Public method | StepMotorAtPower(OutputPort, Int32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified power for the specified number of steps.
Public method | StepMotorAtPower(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified power for the specified number of steps.
Back to Top
See Also
Command Class
Command Members


Command.StepMotorAtPower Method (OutputPort, Int32, UInt32, Boolean)

Command StepMotorAtPower Method (OutputPort, Int32, UInt32, Boolean) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Step the motor connected to the specified port or ports at the specified power for the specified number of steps.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void StepMotorAtPower(
    OutputPort ports,
    int power,
    uint steps,
    bool brake
)
public void StepMotorAtPower(
    OutputPort ports,
    int power,
    uint steps,
    bool brake
)
Public Sub StepMotorAtPower (
    ports As OutputPort,
    power As Integer,
    steps As UInteger,
    brake As Boolean
)
Public Sub StepMotorAtPower (
    ports As OutputPort,
    power As Integer,
    steps As UInteger,
    brake As Boolean
)
public:
void StepMotorAtPower(
    OutputPort ports,
    int power,
    unsigned int steps,
    bool brake
)
public:
void StepMotorAtPower(
    OutputPort ports,
    int power,
    unsigned int steps,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
A specific port or Ports.All.
power
Type:   Online System Int32
The power at which to turn the motor (-100% to 100%).
steps
Type:   Online System UInt32
The number of steps to turn the motor.
brake
Type:   Online System Boolean
Apply brake to motor at end of routine.
See Also
Command Class
Command Members
StepMotorAtPower Overload


Command.StepMotorAtPower Method (OutputPort, Int32, UInt32, UInt32, UInt32, Boolean)

Command StepMotorAtPower Method (OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Step the motor connected to the specified port or ports at the specified power for the specified number of steps.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void StepMotorAtPower(
    OutputPort ports,
    int power,
    uint rampUpSteps,
    uint constantSteps,
    uint rampDownSteps,
    bool brake
)
public void StepMotorAtPower(
    OutputPort ports,
    int power,
    uint rampUpSteps,
    uint constantSteps,
    uint rampDownSteps,
    bool brake
)
Public Sub StepMotorAtPower (
    ports As OutputPort,
    power As Integer,
    rampUpSteps As UInteger,
    constantSteps As UInteger,
    rampDownSteps As UInteger,
    brake As Boolean
)
Public Sub StepMotorAtPower (
    ports As OutputPort,
    power As Integer,
    rampUpSteps As UInteger,
    constantSteps As UInteger,
    rampDownSteps As UInteger,
    brake As Boolean
)
public:
void StepMotorAtPower(
    OutputPort ports,
    int power,
    unsigned int rampUpSteps,
    unsigned int constantSteps,
    unsigned int rampDownSteps,
    bool brake
)
public:
void StepMotorAtPower(
    OutputPort ports,
    int power,
    unsigned int rampUpSteps,
    unsigned int constantSteps,
    unsigned int rampDownSteps,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
A specific port or Ports.All.
power
Type:   Online System Int32
The power at which to turn the motor (-100% to 100%).
rampUpSteps
Type:   Online System UInt32
[Missing <param name="rampUpSteps"/> documentation for "M:Lego.Ev3.Core.Command.StepMotorAtPower(Lego.Ev3.Core.OutputPort,System.Int32,System.UInt32,System.UInt32,System.UInt32,System.Boolean)"]
constantSteps
Type:   Online System UInt32
[Missing <param name="constantSteps"/> documentation for "M:Lego.Ev3.Core.Command.StepMotorAtPower(Lego.Ev3.Core.OutputPort,System.Int32,System.UInt32,System.UInt32,System.UInt32,System.Boolean)"]
rampDownSteps
Type:   Online System UInt32
[Missing <param name="rampDownSteps"/> documentation for "M:Lego.Ev3.Core.Command.StepMotorAtPower(Lego.Ev3.Core.OutputPort,System.Int32,System.UInt32,System.UInt32,System.UInt32,System.Boolean)"]
brake
Type:   Online System Boolean
Apply brake to motor at end of routine.
See Also
Command Class
Command Members
StepMotorAtPower Overload


Command.StepMotorAtSpeed Method

Command StepMotorAtSpeed Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Overload List
 | Name | Description
Public method | StepMotorAtSpeed(OutputPort, Int32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified speed for the specified number of steps.
Public method | StepMotorAtSpeed(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified speed for the specified number of steps.
Back to Top
See Also
Command Class
Command Members


Command.StepMotorAtSpeed Method (OutputPort, Int32, UInt32, Boolean)

Command StepMotorAtSpeed Method (OutputPort, Int32, UInt32, Boolean) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Step the motor connected to the specified port or ports at the specified speed for the specified number of steps.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void StepMotorAtSpeed(
    OutputPort ports,
    int speed,
    uint steps,
    bool brake
)
public void StepMotorAtSpeed(
    OutputPort ports,
    int speed,
    uint steps,
    bool brake
)
Public Sub StepMotorAtSpeed (
    ports As OutputPort,
    speed As Integer,
    steps As UInteger,
    brake As Boolean
)
Public Sub StepMotorAtSpeed (
    ports As OutputPort,
    speed As Integer,
    steps As UInteger,
    brake As Boolean
)
public:
void StepMotorAtSpeed(
    OutputPort ports,
    int speed,
    unsigned int steps,
    bool brake
)
public:
void StepMotorAtSpeed(
    OutputPort ports,
    int speed,
    unsigned int steps,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
A specific port or Ports.All.
speed
Type:   Online System Int32
The speed at which to turn the motor (-100% to 100%).
steps
Type:   Online System UInt32
[Missing <param name="steps"/> documentation for "M:Lego.Ev3.Core.Command.StepMotorAtSpeed(Lego.Ev3.Core.OutputPort,System.Int32,System.UInt32,System.Boolean)"]
brake
Type:   Online System Boolean
Apply brake to motor at end of routine.
See Also
Command Class
Command Members
StepMotorAtSpeed Overload


Command.StepMotorAtSpeed Method (OutputPort, Int32, UInt32, UInt32, UInt32, Boolean)

Command StepMotorAtSpeed Method (OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Step the motor connected to the specified port or ports at the specified speed for the specified number of steps.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void StepMotorAtSpeed(
    OutputPort ports,
    int speed,
    uint rampUpSteps,
    uint constantSteps,
    uint rampDownSteps,
    bool brake
)
public void StepMotorAtSpeed(
    OutputPort ports,
    int speed,
    uint rampUpSteps,
    uint constantSteps,
    uint rampDownSteps,
    bool brake
)
Public Sub StepMotorAtSpeed (
    ports As OutputPort,
    speed As Integer,
    rampUpSteps As UInteger,
    constantSteps As UInteger,
    rampDownSteps As UInteger,
    brake As Boolean
)
Public Sub StepMotorAtSpeed (
    ports As OutputPort,
    speed As Integer,
    rampUpSteps As UInteger,
    constantSteps As UInteger,
    rampDownSteps As UInteger,
    brake As Boolean
)
public:
void StepMotorAtSpeed(
    OutputPort ports,
    int speed,
    unsigned int rampUpSteps,
    unsigned int constantSteps,
    unsigned int rampDownSteps,
    bool brake
)
public:
void StepMotorAtSpeed(
    OutputPort ports,
    int speed,
    unsigned int rampUpSteps,
    unsigned int constantSteps,
    unsigned int rampDownSteps,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
A specific port or Ports.All.
speed
Type:   Online System Int32
The speed at which to turn the motor (-100% to 100%).
rampUpSteps
Type:   Online System UInt32
[Missing <param name="rampUpSteps"/> documentation for "M:Lego.Ev3.Core.Command.StepMotorAtSpeed(Lego.Ev3.Core.OutputPort,System.Int32,System.UInt32,System.UInt32,System.UInt32,System.Boolean)"]
constantSteps
Type:   Online System UInt32
[Missing <param name="constantSteps"/> documentation for "M:Lego.Ev3.Core.Command.StepMotorAtSpeed(Lego.Ev3.Core.OutputPort,System.Int32,System.UInt32,System.UInt32,System.UInt32,System.Boolean)"]
rampDownSteps
Type:   Online System UInt32
[Missing <param name="rampDownSteps"/> documentation for "M:Lego.Ev3.Core.Command.StepMotorAtSpeed(Lego.Ev3.Core.OutputPort,System.Int32,System.UInt32,System.UInt32,System.UInt32,System.Boolean)"]
brake
Type:   Online System Boolean
Apply brake to motor at end of routine.
See Also
Command Class
Command Members
StepMotorAtSpeed Overload


Command.StepMotorSync Method

Command StepMotorSync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Synchronize stepping of motors.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void StepMotorSync(
    OutputPort ports,
    int speed,
    short turnRatio,
    uint step,
    bool brake
)
public void StepMotorSync(
    OutputPort ports,
    int speed,
    short turnRatio,
    uint step,
    bool brake
)
Public Sub StepMotorSync (
    ports As OutputPort,
    speed As Integer,
    turnRatio As Short,
    step As UInteger,
    brake As Boolean
)
Public Sub StepMotorSync (
    ports As OutputPort,
    speed As Integer,
    turnRatio As Short,
    step As UInteger,
    brake As Boolean
)
public:
void StepMotorSync(
    OutputPort ports,
    int speed,
    short turnRatio,
    unsigned int step,
    bool brake
)
public:
void StepMotorSync(
    OutputPort ports,
    int speed,
    short turnRatio,
    unsigned int step,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
The port or ports to which the stop command will be sent.
speed
Type:   Online System Int32
Speed to turn the motor(s). (-100 to 100)
turnRatio
Type:   Online System Int16
The turn ratio to apply. (-200 to 200)
step
Type:   Online System UInt32
The number of steps to turn the motor(s).
brake
Type:   Online System Boolean
Brake or coast at the end.
Return Value
Type:
See Also
Command Class
Command Members


Command.StopMotor Method

Command StopMotor Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Stop Motor command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void StopMotor(
    OutputPort ports,
    bool brake
)
public void StopMotor(
    OutputPort ports,
    bool brake
)
Public Sub StopMotor (
    ports As OutputPort,
    brake As Boolean
)
Public Sub StopMotor (
    ports As OutputPort,
    brake As Boolean
)
public:
void StopMotor(
    OutputPort ports,
    bool brake
)
public:
void StopMotor(
    OutputPort ports,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
Port or ports to stop
brake
Type:   Online System Boolean
Apply the brake at the end of the command
See Also
Command Class
Command Members


Command.TimeMotorSync Method

Command TimeMotorSync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Synchronize timing of motors.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void TimeMotorSync(
    OutputPort ports,
    int speed,
    short turnRatio,
    uint time,
    bool brake
)
public void TimeMotorSync(
    OutputPort ports,
    int speed,
    short turnRatio,
    uint time,
    bool brake
)
Public Sub TimeMotorSync (
    ports As OutputPort,
    speed As Integer,
    turnRatio As Short,
    time As UInteger,
    brake As Boolean
)
Public Sub TimeMotorSync (
    ports As OutputPort,
    speed As Integer,
    turnRatio As Short,
    time As UInteger,
    brake As Boolean
)
public:
void TimeMotorSync(
    OutputPort ports,
    int speed,
    short turnRatio,
    unsigned int time,
    bool brake
)
public:
void TimeMotorSync(
    OutputPort ports,
    int speed,
    short turnRatio,
    unsigned int time,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
The port or ports to which the stop command will be sent.
speed
Type:   Online System Int32
Speed to turn the motor(s). (-100 to 100)
turnRatio
Type:   Online System Int16
The turn ratio to apply. (-200 to 200)
time
Type:   Online System UInt32
The time to turn the motor(s).
brake
Type:   Online System Boolean
Brake or coast at the end.
Return Value
Type:
See Also
Command Class
Command Members


Command.TurnMotorAtPower Method

Command TurnMotorAtPower Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Turns the specified motor at the specified power

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void TurnMotorAtPower(
    OutputPort ports,
    int power
)
public void TurnMotorAtPower(
    OutputPort ports,
    int power
)
Public Sub TurnMotorAtPower (
    ports As OutputPort,
    power As Integer
)
Public Sub TurnMotorAtPower (
    ports As OutputPort,
    power As Integer
)
public:
void TurnMotorAtPower(
    OutputPort ports,
    int power
)
public:
void TurnMotorAtPower(
    OutputPort ports,
    int power
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
Port or ports to apply the command to.
power
Type:   Online System Int32
The amount of power to apply to the specified motors (-100% to 100%).
See Also
Command Class
Command Members


Command.TurnMotorAtPowerForTime Method

Command TurnMotorAtPowerForTime Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Overload List
 | Name | Description
Public method | TurnMotorAtPowerForTime(OutputPort, Int32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified power for the specified times.
Public method | TurnMotorAtPowerForTime(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified power for the specified times.
Back to Top
See Also
Command Class
Command Members


Command.TurnMotorAtPowerForTime Method (OutputPort, Int32, UInt32, Boolean)

Command TurnMotorAtPowerForTime Method (OutputPort, Int32, UInt32, Boolean) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Turn the motor connected to the specified port or ports at the specified power for the specified times.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void TurnMotorAtPowerForTime(
    OutputPort ports,
    int power,
    uint milliseconds,
    bool brake
)
public void TurnMotorAtPowerForTime(
    OutputPort ports,
    int power,
    uint milliseconds,
    bool brake
)
Public Sub TurnMotorAtPowerForTime (
    ports As OutputPort,
    power As Integer,
    milliseconds As UInteger,
    brake As Boolean
)
Public Sub TurnMotorAtPowerForTime (
    ports As OutputPort,
    power As Integer,
    milliseconds As UInteger,
    brake As Boolean
)
public:
void TurnMotorAtPowerForTime(
    OutputPort ports,
    int power,
    unsigned int milliseconds,
    bool brake
)
public:
void TurnMotorAtPowerForTime(
    OutputPort ports,
    int power,
    unsigned int milliseconds,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
A specific port or Ports.All.
power
Type:   Online System Int32
The power at which to turn the motor (-100% to 100%).
milliseconds
Type:   Online System UInt32
Number of milliseconds to run at constant power.
brake
Type:   Online System Boolean
Apply brake to motor at end of routine.
Return Value
Type:
See Also
Command Class
Command Members
TurnMotorAtPowerForTime Overload


Command.TurnMotorAtPowerForTime Method (OutputPort, Int32, UInt32, UInt32, UInt32, Boolean)

Command TurnMotorAtPowerForTime Method (OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Turn the motor connected to the specified port or ports at the specified power for the specified times.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void TurnMotorAtPowerForTime(
    OutputPort ports,
    int power,
    uint msRampUp,
    uint msConstant,
    uint msRampDown,
    bool brake
)
public void TurnMotorAtPowerForTime(
    OutputPort ports,
    int power,
    uint msRampUp,
    uint msConstant,
    uint msRampDown,
    bool brake
)
Public Sub TurnMotorAtPowerForTime (
    ports As OutputPort,
    power As Integer,
    msRampUp As UInteger,
    msConstant As UInteger,
    msRampDown As UInteger,
    brake As Boolean
)
Public Sub TurnMotorAtPowerForTime (
    ports As OutputPort,
    power As Integer,
    msRampUp As UInteger,
    msConstant As UInteger,
    msRampDown As UInteger,
    brake As Boolean
)
public:
void TurnMotorAtPowerForTime(
    OutputPort ports,
    int power,
    unsigned int msRampUp,
    unsigned int msConstant,
    unsigned int msRampDown,
    bool brake
)
public:
void TurnMotorAtPowerForTime(
    OutputPort ports,
    int power,
    unsigned int msRampUp,
    unsigned int msConstant,
    unsigned int msRampDown,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
A specific port or Ports.All.
power
Type:   Online System Int32
The power at which to turn the motor (-100% to 100%).
msRampUp
Type:   Online System UInt32
Number of milliseconds to get up to power.
msConstant
Type:   Online System UInt32
Number of milliseconds to run at constant power.
msRampDown
Type:   Online System UInt32
Number of milliseconds to power down to a stop.
brake
Type:   Online System Boolean
Apply brake to motor at end of routine.
Return Value
Type:
See Also
Command Class
Command Members
TurnMotorAtPowerForTime Overload


Command.TurnMotorAtSpeed Method

Command TurnMotorAtSpeed Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Turn the specified motor at the specified speed.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void TurnMotorAtSpeed(
    OutputPort ports,
    int speed
)
public void TurnMotorAtSpeed(
    OutputPort ports,
    int speed
)
Public Sub TurnMotorAtSpeed (
    ports As OutputPort,
    speed As Integer
)
Public Sub TurnMotorAtSpeed (
    ports As OutputPort,
    speed As Integer
)
public:
void TurnMotorAtSpeed(
    OutputPort ports,
    int speed
)
public:
void TurnMotorAtSpeed(
    OutputPort ports,
    int speed
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
Port or ports to apply the command to.
speed
Type:   Online System Int32
The speed to apply to the specified motors (-100% to 100%).
See Also
Command Class
Command Members


Command.TurnMotorAtSpeedForTime Method

Command TurnMotorAtSpeedForTime Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Overload List
 | Name | Description
Public method | TurnMotorAtSpeedForTime(OutputPort, Int32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified speed for the specified times.
Public method | TurnMotorAtSpeedForTime(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified speed for the specified times.
Back to Top
See Also
Command Class
Command Members


Command.TurnMotorAtSpeedForTime Method (OutputPort, Int32, UInt32, Boolean)

Command TurnMotorAtSpeedForTime Method (OutputPort, Int32, UInt32, Boolean) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Turn the motor connected to the specified port or ports at the specified speed for the specified times.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void TurnMotorAtSpeedForTime(
    OutputPort ports,
    int speed,
    uint milliseconds,
    bool brake
)
public void TurnMotorAtSpeedForTime(
    OutputPort ports,
    int speed,
    uint milliseconds,
    bool brake
)
Public Sub TurnMotorAtSpeedForTime (
    ports As OutputPort,
    speed As Integer,
    milliseconds As UInteger,
    brake As Boolean
)
Public Sub TurnMotorAtSpeedForTime (
    ports As OutputPort,
    speed As Integer,
    milliseconds As UInteger,
    brake As Boolean
)
public:
void TurnMotorAtSpeedForTime(
    OutputPort ports,
    int speed,
    unsigned int milliseconds,
    bool brake
)
public:
void TurnMotorAtSpeedForTime(
    OutputPort ports,
    int speed,
    unsigned int milliseconds,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
A specific port or Ports.All.
speed
Type:   Online System Int32
The power at which to turn the motor (-100% to 100%).
milliseconds
Type:   Online System UInt32
Number of milliseconds to run at constant speed.
brake
Type:   Online System Boolean
Apply brake to motor at end of routine.
Return Value
Type:
See Also
Command Class
Command Members
TurnMotorAtSpeedForTime Overload


Command.TurnMotorAtSpeedForTime Method (OutputPort, Int32, UInt32, UInt32, UInt32, Boolean)

Command TurnMotorAtSpeedForTime Method (OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Turn the motor connected to the specified port or ports at the specified speed for the specified times.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void TurnMotorAtSpeedForTime(
    OutputPort ports,
    int speed,
    uint msRampUp,
    uint msConstant,
    uint msRampDown,
    bool brake
)
public void TurnMotorAtSpeedForTime(
    OutputPort ports,
    int speed,
    uint msRampUp,
    uint msConstant,
    uint msRampDown,
    bool brake
)
Public Sub TurnMotorAtSpeedForTime (
    ports As OutputPort,
    speed As Integer,
    msRampUp As UInteger,
    msConstant As UInteger,
    msRampDown As UInteger,
    brake As Boolean
)
Public Sub TurnMotorAtSpeedForTime (
    ports As OutputPort,
    speed As Integer,
    msRampUp As UInteger,
    msConstant As UInteger,
    msRampDown As UInteger,
    brake As Boolean
)
public:
void TurnMotorAtSpeedForTime(
    OutputPort ports,
    int speed,
    unsigned int msRampUp,
    unsigned int msConstant,
    unsigned int msRampDown,
    bool brake
)
public:
void TurnMotorAtSpeedForTime(
    OutputPort ports,
    int speed,
    unsigned int msRampUp,
    unsigned int msConstant,
    unsigned int msRampDown,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
A specific port or Ports.All.
speed
Type:   Online System Int32
The power at which to turn the motor (-100% to 100%).
msRampUp
Type:   Online System UInt32
Number of milliseconds to get up to speed.
msConstant
Type:   Online System UInt32
Number of milliseconds to run at constant speed.
msRampDown
Type:   Online System UInt32
Number of milliseconds to slow down to a stop.
brake
Type:   Online System Boolean
Apply brake to motor at end of routine.
Return Value
Type:
See Also
Command Class
Command Members
TurnMotorAtSpeedForTime Overload


Command.UpdateUI Method

Command UpdateUI Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Append the Update UI command to an existing Command object

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void UpdateUI()
public void UpdateUI()
Public Sub UpdateUI
Public Sub UpdateUI
public:
void UpdateUI()
public:
void UpdateUI()
See Also
Command Class
Command Members


CommandType Enumeration

CommandType Enumeration LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

The type of command being sent to the brick

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum CommandType
public enum CommandType
Public Enumeration CommandType
Public Enumeration CommandType
public enum class CommandType
public enum class CommandType
Members
Member name | Value | Description
DirectReply | 0 | Direct command with a reply expected
DirectNoReply | 128 | Direct command with no reply
SystemReply | 1 | System command with a reply expected
SystemNoReply | 129 | System command with no reply


DeviceType Enumeration

DeviceType Enumeration LEGO Mindstorms EV3 API Documentation

List of devices which can be recognized as input or output devices

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum DeviceType
public enum DeviceType
Public Enumeration DeviceType
Public Enumeration DeviceType
public enum class DeviceType
public enum class DeviceType
Members
Member name | Value | Description
NxtTouch | 1 | NXT Touch sensor
NxtLight | 2 | NXT Light sensor
NxtSound | 3 | NXT Sound sensor
NxtColor | 4 | NXT Color sensor
NxtUltrasonic | 5 | NXT Ultrasonic sensor
NxtTemperature | 6 | NXT Temperature sensor
LMotor | 7 | Large motor
MMotor | 8 | Medium motor
Touch | 16 | EV3 Touch sensor
Color | 29 | EV3 Color sensor
Ultrasonic | 30 | EV3 Ultrasonic sensor
Gyroscope | 32 | EV3 Gyroscope sensor
Infrared | 33 | EV3 IR sensor
Initializing | 125 | Sensor is initializing
Empty | 126 | Port is empty
WrongPort | 127 | Sensor is plugged into a motor port, or vice-versa
Unknown | 255 | Unknown sensor/status


DirectCommand Class

DirectCommand Class LEGO Mindstorms EV3 API Documentation

Direct commands for the EV3 brick
Inheritance Hierarchy
Online System Object
Lego.Ev3.Core DirectCommand

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class DirectCommand
public sealed class DirectCommand
Public NotInheritable Class DirectCommand
Public NotInheritable Class DirectCommand
public ref class DirectCommand sealed
public ref class DirectCommand sealed
See Also
DirectCommand Members


DirectCommand Members

DirectCommand Members LEGO Mindstorms EV3 API Documentation

The DirectCommand type exposes the following members.
Methods
 | Name | Description
Public method | CleanUIAsync | Clear the entire screen
Public method | ClearAllDevices | Resets all ports and devices to defaults.
Public method | ClearChanges | Clears changes on specified port
Public method | DrawCircleAsync | Draw a circle
Public method | DrawDottedLineAsync | Draw a dotted line
Public method | DrawFillWindowAsync | Fills the width of the screen between the provided Y coordinates
Public method | DrawImageAsync | Draw an image to the LCD screen
Public method | DrawInverseRectangleAsync | Draw a filled rectangle, inverting the pixels underneath it
Public method | DrawLineAsync | Draw a line on the EV3 LCD screen
Public method | DrawPixelAsync | Draw a single pixel
Public method | DrawRectangleAsync | Draw a rectangle
Public method | DrawTextAsync | Write a string to the screen
Public method | EnableTopLineAsync | Enable or disable the top status bar
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDeviceNameAsync | Get the name of the device attached to the specified port
Public method | GetFirmwareVersionAsync | Return the current version number of the firmware running on the EV3 brick.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetModeNameAsync | Get the mode of the device attached to the specified port
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeModeAsync | Get the type and mode of the device attached to the specified port
Public method | IsBrickButtonPressedAsync | Returns whether the specified BrickButton is pressed
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PlaySoundAsync | Play a sound file stored on the EV3 brick
Public method | PlayToneAsync | Plays a tone of the specified frequency for the specified time.
Public method | ReadyPercentAsync | Read the percent value from the specified port in the specified mode
Public method | ReadyRawAsync | Read the raw value from the specified port in the specified mode
Public method | ReadySIAsync | Read the SI value from the specified port in the specified mode
Public method | SelectFontAsync | Select the font for text drawing
Public method | SetLedPatternAsync | Set EV3 brick LED pattern
Public method | SetMotorPolarity | Set the polarity (direction) of a motor.
Public method | StartMotorAsync | Start motors on the specified ports.
Public method | StepMotorAtPowerAsync(OutputPort, Int32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified power for the specified number of steps.
Public method | StepMotorAtPowerAsync(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified power for the specified number of steps.
Public method | StepMotorAtSpeedAsync(OutputPort, Int32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified speed for the specified number of steps.
Public method | StepMotorAtSpeedAsync(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified speed for the specified number of steps.
Public method | StepMotorSyncAsync | Synchronize stepping of motors.
Public method | StopMotorAsync | Stops motors on the specified ports.
Public method | TimeMotorSyncAsync | Synchronize timing of motors.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TurnMotorAtPowerAsync | Turn the motor connected to the specified port or ports at the specified power.
Public method | TurnMotorAtPowerForTimeAsync(OutputPort, Int32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified power for the specified times.
Public method | TurnMotorAtPowerForTimeAsync(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified power for the specified times.
Public method | TurnMotorAtSpeedAsync | Turn the specified motor at the specified speed.
Public method | TurnMotorAtSpeedForTimeAsync(OutputPort, Int32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified speed for the specified times.
Public method | TurnMotorAtSpeedForTimeAsync(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified speed for the specified times.
Public method | UpdateUIAsync | Refresh the EV3 LCD screen
Back to Top
See Also
DirectCommand Class


DirectCommand Methods

DirectCommand Methods LEGO Mindstorms EV3 API Documentation

The DirectCommand type exposes the following members.
Methods
 | Name | Description
Public method | CleanUIAsync | Clear the entire screen
Public method | ClearAllDevices | Resets all ports and devices to defaults.
Public method | ClearChanges | Clears changes on specified port
Public method | DrawCircleAsync | Draw a circle
Public method | DrawDottedLineAsync | Draw a dotted line
Public method | DrawFillWindowAsync | Fills the width of the screen between the provided Y coordinates
Public method | DrawImageAsync | Draw an image to the LCD screen
Public method | DrawInverseRectangleAsync | Draw a filled rectangle, inverting the pixels underneath it
Public method | DrawLineAsync | Draw a line on the EV3 LCD screen
Public method | DrawPixelAsync | Draw a single pixel
Public method | DrawRectangleAsync | Draw a rectangle
Public method | DrawTextAsync | Write a string to the screen
Public method | EnableTopLineAsync | Enable or disable the top status bar
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDeviceNameAsync | Get the name of the device attached to the specified port
Public method | GetFirmwareVersionAsync | Return the current version number of the firmware running on the EV3 brick.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetModeNameAsync | Get the mode of the device attached to the specified port
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeModeAsync | Get the type and mode of the device attached to the specified port
Public method | IsBrickButtonPressedAsync | Returns whether the specified BrickButton is pressed
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PlaySoundAsync | Play a sound file stored on the EV3 brick
Public method | PlayToneAsync | Plays a tone of the specified frequency for the specified time.
Public method | ReadyPercentAsync | Read the percent value from the specified port in the specified mode
Public method | ReadyRawAsync | Read the raw value from the specified port in the specified mode
Public method | ReadySIAsync | Read the SI value from the specified port in the specified mode
Public method | SelectFontAsync | Select the font for text drawing
Public method | SetLedPatternAsync | Set EV3 brick LED pattern
Public method | SetMotorPolarity | Set the polarity (direction) of a motor.
Public method | StartMotorAsync | Start motors on the specified ports.
Public method | StepMotorAtPowerAsync(OutputPort, Int32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified power for the specified number of steps.
Public method | StepMotorAtPowerAsync(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified power for the specified number of steps.
Public method | StepMotorAtSpeedAsync(OutputPort, Int32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified speed for the specified number of steps.
Public method | StepMotorAtSpeedAsync(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified speed for the specified number of steps.
Public method | StepMotorSyncAsync | Synchronize stepping of motors.
Public method | StopMotorAsync | Stops motors on the specified ports.
Public method | TimeMotorSyncAsync | Synchronize timing of motors.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TurnMotorAtPowerAsync | Turn the motor connected to the specified port or ports at the specified power.
Public method | TurnMotorAtPowerForTimeAsync(OutputPort, Int32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified power for the specified times.
Public method | TurnMotorAtPowerForTimeAsync(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified power for the specified times.
Public method | TurnMotorAtSpeedAsync | Turn the specified motor at the specified speed.
Public method | TurnMotorAtSpeedForTimeAsync(OutputPort, Int32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified speed for the specified times.
Public method | TurnMotorAtSpeedForTimeAsync(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified speed for the specified times.
Public method | UpdateUIAsync | Refresh the EV3 LCD screen
Back to Top
See Also
DirectCommand Class


DirectCommand.CleanUIAsync Method

DirectCommand CleanUIAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Clear the entire screen

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task CleanUIAsync()
public Task CleanUIAsync()
Public Function CleanUIAsync As Task
Public Function CleanUIAsync As Task
public:
Task^ CleanUIAsync()
public:
Task^ CleanUIAsync()
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.ClearAllDevices Method

DirectCommand ClearAllDevices Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Resets all ports and devices to defaults.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task ClearAllDevices()
public Task ClearAllDevices()
Public Function ClearAllDevices As Task
Public Function ClearAllDevices As Task
public:
Task^ ClearAllDevices()
public:
Task^ ClearAllDevices()
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.ClearChanges Method

DirectCommand ClearChanges Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Clears changes on specified port

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task ClearChanges(
    InputPort port
)
public Task ClearChanges(
    InputPort port
)
Public Function ClearChanges (
    port As InputPort
) As Task
Public Function ClearChanges (
    port As InputPort
) As Task
public:
Task^ ClearChanges(
    InputPort port
)
public:
Task^ ClearChanges(
    InputPort port
)
Parameters
port
Type: Lego.Ev3.Core InputPort
The port to clear
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.DrawCircleAsync Method

DirectCommand DrawCircleAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Draw a circle

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task DrawCircleAsync(
    Color color,
    ushort x,
    ushort y,
    ushort radius,
    bool filled
)
public Task DrawCircleAsync(
    Color color,
    ushort x,
    ushort y,
    ushort radius,
    bool filled
)
Public Function DrawCircleAsync (
    color As Color,
    x As UShort,
    y As UShort,
    radius As UShort,
    filled As Boolean
) As Task
Public Function DrawCircleAsync (
    color As Color,
    x As UShort,
    y As UShort,
    radius As UShort,
    filled As Boolean
) As Task
public:
Task^ DrawCircleAsync(
    Color color,
    unsigned short x,
    unsigned short y,
    unsigned short radius,
    bool filled
)
public:
Task^ DrawCircleAsync(
    Color color,
    unsigned short x,
    unsigned short y,
    unsigned short radius,
    bool filled
)
Parameters
color
Type: Lego.Ev3.Core Color
Color of the circle
x
Type:   Online System UInt16
X position
y
Type:   Online System UInt16
Y position
radius
Type:   Online System UInt16
Radius of the circle
filled
Type:   Online System Boolean
Filled or empty
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.DrawDottedLineAsync Method

DirectCommand DrawDottedLineAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Draw a dotted line

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task DrawDottedLineAsync(
    Color color,
    ushort x0,
    ushort y0,
    ushort x1,
    ushort y1,
    ushort onPixels,
    ushort offPixels
)
public Task DrawDottedLineAsync(
    Color color,
    ushort x0,
    ushort y0,
    ushort x1,
    ushort y1,
    ushort onPixels,
    ushort offPixels
)
Public Function DrawDottedLineAsync (
    color As Color,
    x0 As UShort,
    y0 As UShort,
    x1 As UShort,
    y1 As UShort,
    onPixels As UShort,
    offPixels As UShort
) As Task
Public Function DrawDottedLineAsync (
    color As Color,
    x0 As UShort,
    y0 As UShort,
    x1 As UShort,
    y1 As UShort,
    onPixels As UShort,
    offPixels As UShort
) As Task
public:
Task^ DrawDottedLineAsync(
    Color color,
    unsigned short x0,
    unsigned short y0,
    unsigned short x1,
    unsigned short y1,
    unsigned short onPixels,
    unsigned short offPixels
)
public:
Task^ DrawDottedLineAsync(
    Color color,
    unsigned short x0,
    unsigned short y0,
    unsigned short x1,
    unsigned short y1,
    unsigned short onPixels,
    unsigned short offPixels
)
Parameters
color
Type: Lego.Ev3.Core Color
Color of dotted line
x0
Type:   Online System UInt16
X start
y0
Type:   Online System UInt16
Y start
x1
Type:   Online System UInt16
X end
y1
Type:   Online System UInt16
Y end
onPixels
Type:   Online System UInt16
Number of pixels the line is drawn
offPixels
Type:   Online System UInt16
Number of pixels the line is empty
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.DrawFillWindowAsync Method

DirectCommand DrawFillWindowAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Fills the width of the screen between the provided Y coordinates

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task DrawFillWindowAsync(
    Color color,
    ushort y0,
    ushort y1
)
public Task DrawFillWindowAsync(
    Color color,
    ushort y0,
    ushort y1
)
Public Function DrawFillWindowAsync (
    color As Color,
    y0 As UShort,
    y1 As UShort
) As Task
Public Function DrawFillWindowAsync (
    color As Color,
    y0 As UShort,
    y1 As UShort
) As Task
public:
Task^ DrawFillWindowAsync(
    Color color,
    unsigned short y0,
    unsigned short y1
)
public:
Task^ DrawFillWindowAsync(
    Color color,
    unsigned short y0,
    unsigned short y1
)
Parameters
color
Type: Lego.Ev3.Core Color
Color of the fill
y0
Type:   Online System UInt16
Y start
y1
Type:   Online System UInt16
Y end
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.DrawImageAsync Method

DirectCommand DrawImageAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Draw an image to the LCD screen

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task DrawImageAsync(
    Color color,
    ushort x,
    ushort y,
    string devicePath
)
public Task DrawImageAsync(
    Color color,
    ushort x,
    ushort y,
    string devicePath
)
Public Function DrawImageAsync (
    color As Color,
    x As UShort,
    y As UShort,
    devicePath As String
) As Task
Public Function DrawImageAsync (
    color As Color,
    x As UShort,
    y As UShort,
    devicePath As String
) As Task
public:
Task^ DrawImageAsync(
    Color color,
    unsigned short x,
    unsigned short y,
    String^ devicePath
)
public:
Task^ DrawImageAsync(
    Color color,
    unsigned short x,
    unsigned short y,
    String^ devicePath
)
Parameters
color
Type: Lego.Ev3.Core Color
Color of the image pixels
x
Type:   Online System UInt16
X position
y
Type:   Online System UInt16
Y position
devicePath
Type:   Online System String
Path to the image on the EV3 brick
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.DrawInverseRectangleAsync Method

DirectCommand DrawInverseRectangleAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Draw a filled rectangle, inverting the pixels underneath it

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task DrawInverseRectangleAsync(
    ushort x,
    ushort y,
    ushort width,
    ushort height
)
public Task DrawInverseRectangleAsync(
    ushort x,
    ushort y,
    ushort width,
    ushort height
)
Public Function DrawInverseRectangleAsync (
    x As UShort,
    y As UShort,
    width As UShort,
    height As UShort
) As Task
Public Function DrawInverseRectangleAsync (
    x As UShort,
    y As UShort,
    width As UShort,
    height As UShort
) As Task
public:
Task^ DrawInverseRectangleAsync(
    unsigned short x,
    unsigned short y,
    unsigned short width,
    unsigned short height
)
public:
Task^ DrawInverseRectangleAsync(
    unsigned short x,
    unsigned short y,
    unsigned short width,
    unsigned short height
)
Parameters
x
Type:   Online System UInt16
X position
y
Type:   Online System UInt16
Y position
width
Type:   Online System UInt16
Width of the rectangle
height
Type:   Online System UInt16
Height of the rectangle
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.DrawLineAsync Method

DirectCommand DrawLineAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Draw a line on the EV3 LCD screen

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task DrawLineAsync(
    Color color,
    ushort x0,
    ushort y0,
    ushort x1,
    ushort y1
)
public Task DrawLineAsync(
    Color color,
    ushort x0,
    ushort y0,
    ushort x1,
    ushort y1
)
Public Function DrawLineAsync (
    color As Color,
    x0 As UShort,
    y0 As UShort,
    x1 As UShort,
    y1 As UShort
) As Task
Public Function DrawLineAsync (
    color As Color,
    x0 As UShort,
    y0 As UShort,
    x1 As UShort,
    y1 As UShort
) As Task
public:
Task^ DrawLineAsync(
    Color color,
    unsigned short x0,
    unsigned short y0,
    unsigned short x1,
    unsigned short y1
)
public:
Task^ DrawLineAsync(
    Color color,
    unsigned short x0,
    unsigned short y0,
    unsigned short x1,
    unsigned short y1
)
Parameters
color
Type: Lego.Ev3.Core Color
Color of the line
x0
Type:   Online System UInt16
X start
y0
Type:   Online System UInt16
Y start
x1
Type:   Online System UInt16
X end
y1
Type:   Online System UInt16
Y end
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.DrawPixelAsync Method

DirectCommand DrawPixelAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Draw a single pixel

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task DrawPixelAsync(
    Color color,
    ushort x,
    ushort y
)
public Task DrawPixelAsync(
    Color color,
    ushort x,
    ushort y
)
Public Function DrawPixelAsync (
    color As Color,
    x As UShort,
    y As UShort
) As Task
Public Function DrawPixelAsync (
    color As Color,
    x As UShort,
    y As UShort
) As Task
public:
Task^ DrawPixelAsync(
    Color color,
    unsigned short x,
    unsigned short y
)
public:
Task^ DrawPixelAsync(
    Color color,
    unsigned short x,
    unsigned short y
)
Parameters
color
Type: Lego.Ev3.Core Color
Color of the pixel
x
Type:   Online System UInt16
X position
y
Type:   Online System UInt16
Y position
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.DrawRectangleAsync Method

DirectCommand DrawRectangleAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Draw a rectangle

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task DrawRectangleAsync(
    Color color,
    ushort x,
    ushort y,
    ushort width,
    ushort height,
    bool filled
)
public Task DrawRectangleAsync(
    Color color,
    ushort x,
    ushort y,
    ushort width,
    ushort height,
    bool filled
)
Public Function DrawRectangleAsync (
    color As Color,
    x As UShort,
    y As UShort,
    width As UShort,
    height As UShort,
    filled As Boolean
) As Task
Public Function DrawRectangleAsync (
    color As Color,
    x As UShort,
    y As UShort,
    width As UShort,
    height As UShort,
    filled As Boolean
) As Task
public:
Task^ DrawRectangleAsync(
    Color color,
    unsigned short x,
    unsigned short y,
    unsigned short width,
    unsigned short height,
    bool filled
)
public:
Task^ DrawRectangleAsync(
    Color color,
    unsigned short x,
    unsigned short y,
    unsigned short width,
    unsigned short height,
    bool filled
)
Parameters
color
Type: Lego.Ev3.Core Color
Color of the rectangle
x
Type:   Online System UInt16
X position
y
Type:   Online System UInt16
Y position
width
Type:   Online System UInt16
Width of rectangle
height
Type:   Online System UInt16
Height of rectangle
filled
Type:   Online System Boolean
Filled or empty
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.DrawTextAsync Method

DirectCommand DrawTextAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Write a string to the screen

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task DrawTextAsync(
    Color color,
    ushort x,
    ushort y,
    string text
)
public Task DrawTextAsync(
    Color color,
    ushort x,
    ushort y,
    string text
)
Public Function DrawTextAsync (
    color As Color,
    x As UShort,
    y As UShort,
    text As String
) As Task
Public Function DrawTextAsync (
    color As Color,
    x As UShort,
    y As UShort,
    text As String
) As Task
public:
Task^ DrawTextAsync(
    Color color,
    unsigned short x,
    unsigned short y,
    String^ text
)
public:
Task^ DrawTextAsync(
    Color color,
    unsigned short x,
    unsigned short y,
    String^ text
)
Parameters
color
Type: Lego.Ev3.Core Color
Color of the text
x
Type:   Online System UInt16
X position
y
Type:   Online System UInt16
Y position
text
Type:   Online System String
Text to draw
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.EnableTopLineAsync Method

DirectCommand EnableTopLineAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Enable or disable the top status bar

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task EnableTopLineAsync(
    bool enabled
)
public Task EnableTopLineAsync(
    bool enabled
)
Public Function EnableTopLineAsync (
    enabled As Boolean
) As Task
Public Function EnableTopLineAsync (
    enabled As Boolean
) As Task
public:
Task^ EnableTopLineAsync(
    bool enabled
)
public:
Task^ EnableTopLineAsync(
    bool enabled
)
Parameters
enabled
Type:   Online System Boolean
Enabled or disabled
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.GetDeviceNameAsync Method

DirectCommand GetDeviceNameAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Get the name of the device attached to the specified port

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<string> GetDeviceNameAsync(
    InputPort port
)
public Task<string> GetDeviceNameAsync(
    InputPort port
)
Public Function GetDeviceNameAsync (
    port As InputPort
) As Task(Of String)
Public Function GetDeviceNameAsync (
    port As InputPort
) As Task(Of String)
public:
Task<String^>^ GetDeviceNameAsync(
    InputPort port
)
public:
Task<String^>^ GetDeviceNameAsync(
    InputPort port
)
Parameters
port
Type: Lego.Ev3.Core InputPort
Port to query
Return Value
Type:   Online Task    Online String
The name of the device
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.GetFirmwareVersionAsync Method

DirectCommand GetFirmwareVersionAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Return the current version number of the firmware running on the EV3 brick.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<string> GetFirmwareVersionAsync()
public Task<string> GetFirmwareVersionAsync()
Public Function GetFirmwareVersionAsync As Task(Of String)
Public Function GetFirmwareVersionAsync As Task(Of String)
public:
Task<String^>^ GetFirmwareVersionAsync()
public:
Task<String^>^ GetFirmwareVersionAsync()
Return Value
Type:   Online Task    Online String
Current firmware version.
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.GetModeNameAsync Method

DirectCommand GetModeNameAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Get the mode of the device attached to the specified port

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<string> GetModeNameAsync(
    InputPort port,
    int mode
)
public Task<string> GetModeNameAsync(
    InputPort port,
    int mode
)
Public Function GetModeNameAsync (
    port As InputPort,
    mode As Integer
) As Task(Of String)
Public Function GetModeNameAsync (
    port As InputPort,
    mode As Integer
) As Task(Of String)
public:
Task<String^>^ GetModeNameAsync(
    InputPort port,
    int mode
)
public:
Task<String^>^ GetModeNameAsync(
    InputPort port,
    int mode
)
Parameters
port
Type: Lego.Ev3.Core InputPort
Port to query
mode
Type:   Online System Int32
Mode of the name to get
Return Value
Type:   Online Task    Online String
The name of the mode
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.GetTypeModeAsync Method

DirectCommand GetTypeModeAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Get the type and mode of the device attached to the specified port

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<byte[]> GetTypeModeAsync(
    InputPort port
)
public Task<byte[]> GetTypeModeAsync(
    InputPort port
)
Public Function GetTypeModeAsync (
    port As InputPort
) As Task(Of Byte())
Public Function GetTypeModeAsync (
    port As InputPort
) As Task(Of Byte())
public:
Task<array<unsigned char>^>^ GetTypeModeAsync(
    InputPort port
)
public:
Task<array<unsigned char>^>^ GetTypeModeAsync(
    InputPort port
)
Parameters
port
Type: Lego.Ev3.Core InputPort
The input port to query
Return Value
Type:   Online Task     Online Byte
2 bytes, index 0 being the type, index 1 being the mode
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.IsBrickButtonPressedAsync Method

DirectCommand IsBrickButtonPressedAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Returns whether the specified BrickButton is pressed

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<bool> IsBrickButtonPressedAsync(
    BrickButton button
)
public Task<bool> IsBrickButtonPressedAsync(
    BrickButton button
)
Public Function IsBrickButtonPressedAsync (
    button As BrickButton
) As Task(Of Boolean)
Public Function IsBrickButtonPressedAsync (
    button As BrickButton
) As Task(Of Boolean)
public:
Task<bool>^ IsBrickButtonPressedAsync(
    BrickButton button
)
public:
Task<bool>^ IsBrickButtonPressedAsync(
    BrickButton button
)
Parameters
button
Type: Lego.Ev3.Core BrickButton
Button on the face of the EV3 brick
Return Value
Type:   Online Task    Online Boolean
Whether or not the button is pressed
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.PlaySoundAsync Method

DirectCommand PlaySoundAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Play a sound file stored on the EV3 brick

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task PlaySoundAsync(
    int volume,
    string filename
)
public Task PlaySoundAsync(
    int volume,
    string filename
)
Public Function PlaySoundAsync (
    volume As Integer,
    filename As String
) As Task
Public Function PlaySoundAsync (
    volume As Integer,
    filename As String
) As Task
public:
Task^ PlaySoundAsync(
    int volume,
    String^ filename
)
public:
Task^ PlaySoundAsync(
    int volume,
    String^ filename
)
Parameters
volume
Type:   Online System Int32
Volume of the sound (0-100)
filename
Type:   Online System String
Filename of sound stored on brick, without the .RSF extension
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.PlayToneAsync Method

DirectCommand PlayToneAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Plays a tone of the specified frequency for the specified time.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task PlayToneAsync(
    int volume,
    ushort frequency,
    ushort duration
)
public Task PlayToneAsync(
    int volume,
    ushort frequency,
    ushort duration
)
Public Function PlayToneAsync (
    volume As Integer,
    frequency As UShort,
    duration As UShort
) As Task
Public Function PlayToneAsync (
    volume As Integer,
    frequency As UShort,
    duration As UShort
) As Task
public:
Task^ PlayToneAsync(
    int volume,
    unsigned short frequency,
    unsigned short duration
)
public:
Task^ PlayToneAsync(
    int volume,
    unsigned short frequency,
    unsigned short duration
)
Parameters
volume
Type:   Online System Int32
Volume of tone (0-100).
frequency
Type:   Online System UInt16
Frequency of tone, in hertz.
duration
Type:   Online System UInt16
Duration to play tone, in milliseconds.
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.ReadyPercentAsync Method

DirectCommand ReadyPercentAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Read the percent value from the specified port in the specified mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<int> ReadyPercentAsync(
    InputPort port,
    int mode
)
public Task<int> ReadyPercentAsync(
    InputPort port,
    int mode
)
Public Function ReadyPercentAsync (
    port As InputPort,
    mode As Integer
) As Task(Of Integer)
Public Function ReadyPercentAsync (
    port As InputPort,
    mode As Integer
) As Task(Of Integer)
public:
Task<int>^ ReadyPercentAsync(
    InputPort port,
    int mode
)
public:
Task<int>^ ReadyPercentAsync(
    InputPort port,
    int mode
)
Parameters
port
Type: Lego.Ev3.Core InputPort
The port to query
mode
Type:   Online System Int32
The mode used to read the data
Return Value
Type:   Online Task    Online Int32
The percentage value
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.ReadyRawAsync Method

DirectCommand ReadyRawAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Read the raw value from the specified port in the specified mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<int> ReadyRawAsync(
    InputPort port,
    int mode
)
public Task<int> ReadyRawAsync(
    InputPort port,
    int mode
)
Public Function ReadyRawAsync (
    port As InputPort,
    mode As Integer
) As Task(Of Integer)
Public Function ReadyRawAsync (
    port As InputPort,
    mode As Integer
) As Task(Of Integer)
public:
Task<int>^ ReadyRawAsync(
    InputPort port,
    int mode
)
public:
Task<int>^ ReadyRawAsync(
    InputPort port,
    int mode
)
Parameters
port
Type: Lego.Ev3.Core InputPort
The port to query
mode
Type:   Online System Int32
The mode used to read the data
Return Value
Type:   Online Task    Online Int32
The Raw value
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.ReadySIAsync Method

DirectCommand ReadySIAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Read the SI value from the specified port in the specified mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<float> ReadySIAsync(
    InputPort port,
    int mode
)
public Task<float> ReadySIAsync(
    InputPort port,
    int mode
)
Public Function ReadySIAsync (
    port As InputPort,
    mode As Integer
) As Task(Of Single)
Public Function ReadySIAsync (
    port As InputPort,
    mode As Integer
) As Task(Of Single)
public:
Task<float>^ ReadySIAsync(
    InputPort port,
    int mode
)
public:
Task<float>^ ReadySIAsync(
    InputPort port,
    int mode
)
Parameters
port
Type: Lego.Ev3.Core InputPort
The port to query
mode
Type:   Online System Int32
The mode used to read the data
Return Value
Type:   Online Task    Online Single
The SI value
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.SelectFontAsync Method

DirectCommand SelectFontAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Select the font for text drawing

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task SelectFontAsync(
    FontType fontType
)
public Task SelectFontAsync(
    FontType fontType
)
Public Function SelectFontAsync (
    fontType As FontType
) As Task
Public Function SelectFontAsync (
    fontType As FontType
) As Task
public:
Task^ SelectFontAsync(
    FontType fontType
)
public:
Task^ SelectFontAsync(
    FontType fontType
)
Parameters
fontType
Type: Lego.Ev3.Core FontType
Type of font to use
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.SetLedPatternAsync Method

DirectCommand SetLedPatternAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Set EV3 brick LED pattern

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task SetLedPatternAsync(
    LedPattern ledPattern
)
public Task SetLedPatternAsync(
    LedPattern ledPattern
)
Public Function SetLedPatternAsync (
    ledPattern As LedPattern
) As Task
Public Function SetLedPatternAsync (
    ledPattern As LedPattern
) As Task
public:
Task^ SetLedPatternAsync(
    LedPattern ledPattern
)
public:
Task^ SetLedPatternAsync(
    LedPattern ledPattern
)
Parameters
ledPattern
Type: Lego.Ev3.Core LedPattern
Pattern to display on LED
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.SetMotorPolarity Method

DirectCommand SetMotorPolarity Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Set the polarity (direction) of a motor.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task SetMotorPolarity(
    OutputPort ports,
    Polarity polarity
)
public Task SetMotorPolarity(
    OutputPort ports,
    Polarity polarity
)
Public Function SetMotorPolarity (
    ports As OutputPort,
    polarity As Polarity
) As Task
Public Function SetMotorPolarity (
    ports As OutputPort,
    polarity As Polarity
) As Task
public:
Task^ SetMotorPolarity(
    OutputPort ports,
    Polarity polarity
)
public:
Task^ SetMotorPolarity(
    OutputPort ports,
    Polarity polarity
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
Port or ports to change polarity
polarity
Type: Lego.Ev3.Core Polarity
The new polarity (direction) value
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.StartMotorAsync Method

DirectCommand StartMotorAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Start motors on the specified ports.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task StartMotorAsync(
    OutputPort ports
)
public Task StartMotorAsync(
    OutputPort ports
)
Public Function StartMotorAsync (
    ports As OutputPort
) As Task
Public Function StartMotorAsync (
    ports As OutputPort
) As Task
public:
Task^ StartMotorAsync(
    OutputPort ports
)
public:
Task^ StartMotorAsync(
    OutputPort ports
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
The port or ports to which the stop command will be sent.
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.StepMotorAtPowerAsync Method

DirectCommand StepMotorAtPowerAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Overload List
 | Name | Description
Public method | StepMotorAtPowerAsync(OutputPort, Int32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified power for the specified number of steps.
Public method | StepMotorAtPowerAsync(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified power for the specified number of steps.
Back to Top
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.StepMotorAtPowerAsync Method (OutputPort, Int32, UInt32, Boolean)

DirectCommand StepMotorAtPowerAsync Method (OutputPort, Int32, UInt32, Boolean) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Step the motor connected to the specified port or ports at the specified power for the specified number of steps.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task StepMotorAtPowerAsync(
    OutputPort ports,
    int power,
    uint steps,
    bool brake
)
public Task StepMotorAtPowerAsync(
    OutputPort ports,
    int power,
    uint steps,
    bool brake
)
Public Function StepMotorAtPowerAsync (
    ports As OutputPort,
    power As Integer,
    steps As UInteger,
    brake As Boolean
) As Task
Public Function StepMotorAtPowerAsync (
    ports As OutputPort,
    power As Integer,
    steps As UInteger,
    brake As Boolean
) As Task
public:
Task^ StepMotorAtPowerAsync(
    OutputPort ports,
    int power,
    unsigned int steps,
    bool brake
)
public:
Task^ StepMotorAtPowerAsync(
    OutputPort ports,
    int power,
    unsigned int steps,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
A specific port or Ports.All.
power
Type:   Online System Int32
The power at which to turn the motor (-100 to 100).
steps
Type:   Online System UInt32
[Missing <param name="steps"/> documentation for "M:Lego.Ev3.Core.DirectCommand.StepMotorAtPowerAsync(Lego.Ev3.Core.OutputPort,System.Int32,System.UInt32,System.Boolean)"]
brake
Type:   Online System Boolean
Apply brake to motor at end of routine.
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members
StepMotorAtPowerAsync Overload


DirectCommand.StepMotorAtPowerAsync Method (OutputPort, Int32, UInt32, UInt32, UInt32, Boolean)

DirectCommand StepMotorAtPowerAsync Method (OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Step the motor connected to the specified port or ports at the specified power for the specified number of steps.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task StepMotorAtPowerAsync(
    OutputPort ports,
    int power,
    uint rampUpSteps,
    uint constantSteps,
    uint rampDownSteps,
    bool brake
)
public Task StepMotorAtPowerAsync(
    OutputPort ports,
    int power,
    uint rampUpSteps,
    uint constantSteps,
    uint rampDownSteps,
    bool brake
)
Public Function StepMotorAtPowerAsync (
    ports As OutputPort,
    power As Integer,
    rampUpSteps As UInteger,
    constantSteps As UInteger,
    rampDownSteps As UInteger,
    brake As Boolean
) As Task
Public Function StepMotorAtPowerAsync (
    ports As OutputPort,
    power As Integer,
    rampUpSteps As UInteger,
    constantSteps As UInteger,
    rampDownSteps As UInteger,
    brake As Boolean
) As Task
public:
Task^ StepMotorAtPowerAsync(
    OutputPort ports,
    int power,
    unsigned int rampUpSteps,
    unsigned int constantSteps,
    unsigned int rampDownSteps,
    bool brake
)
public:
Task^ StepMotorAtPowerAsync(
    OutputPort ports,
    int power,
    unsigned int rampUpSteps,
    unsigned int constantSteps,
    unsigned int rampDownSteps,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
A specific port or Ports.All.
power
Type:   Online System Int32
The power at which to turn the motor (-100 to 100).
rampUpSteps
Type:   Online System UInt32
[Missing <param name="rampUpSteps"/> documentation for "M:Lego.Ev3.Core.DirectCommand.StepMotorAtPowerAsync(Lego.Ev3.Core.OutputPort,System.Int32,System.UInt32,System.UInt32,System.UInt32,System.Boolean)"]
constantSteps
Type:   Online System UInt32
[Missing <param name="constantSteps"/> documentation for "M:Lego.Ev3.Core.DirectCommand.StepMotorAtPowerAsync(Lego.Ev3.Core.OutputPort,System.Int32,System.UInt32,System.UInt32,System.UInt32,System.Boolean)"]
rampDownSteps
Type:   Online System UInt32
[Missing <param name="rampDownSteps"/> documentation for "M:Lego.Ev3.Core.DirectCommand.StepMotorAtPowerAsync(Lego.Ev3.Core.OutputPort,System.Int32,System.UInt32,System.UInt32,System.UInt32,System.Boolean)"]
brake
Type:   Online System Boolean
Apply brake to motor at end of routine.
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members
StepMotorAtPowerAsync Overload


DirectCommand.StepMotorAtSpeedAsync Method

DirectCommand StepMotorAtSpeedAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Overload List
 | Name | Description
Public method | StepMotorAtSpeedAsync(OutputPort, Int32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified speed for the specified number of steps.
Public method | StepMotorAtSpeedAsync(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Step the motor connected to the specified port or ports at the specified speed for the specified number of steps.
Back to Top
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.StepMotorAtSpeedAsync Method (OutputPort, Int32, UInt32, Boolean)

DirectCommand StepMotorAtSpeedAsync Method (OutputPort, Int32, UInt32, Boolean) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Step the motor connected to the specified port or ports at the specified speed for the specified number of steps.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task StepMotorAtSpeedAsync(
    OutputPort ports,
    int speed,
    uint steps,
    bool brake
)
public Task StepMotorAtSpeedAsync(
    OutputPort ports,
    int speed,
    uint steps,
    bool brake
)
Public Function StepMotorAtSpeedAsync (
    ports As OutputPort,
    speed As Integer,
    steps As UInteger,
    brake As Boolean
) As Task
Public Function StepMotorAtSpeedAsync (
    ports As OutputPort,
    speed As Integer,
    steps As UInteger,
    brake As Boolean
) As Task
public:
Task^ StepMotorAtSpeedAsync(
    OutputPort ports,
    int speed,
    unsigned int steps,
    bool brake
)
public:
Task^ StepMotorAtSpeedAsync(
    OutputPort ports,
    int speed,
    unsigned int steps,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
A specific port or Ports.All.
speed
Type:   Online System Int32
The speed at which to turn the motor (-100 to 100).
steps
Type:   Online System UInt32
[Missing <param name="steps"/> documentation for "M:Lego.Ev3.Core.DirectCommand.StepMotorAtSpeedAsync(Lego.Ev3.Core.OutputPort,System.Int32,System.UInt32,System.Boolean)"]
brake
Type:   Online System Boolean
Apply brake to motor at end of routine.
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members
StepMotorAtSpeedAsync Overload


DirectCommand.StepMotorAtSpeedAsync Method (OutputPort, Int32, UInt32, UInt32, UInt32, Boolean)

DirectCommand StepMotorAtSpeedAsync Method (OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Step the motor connected to the specified port or ports at the specified speed for the specified number of steps.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task StepMotorAtSpeedAsync(
    OutputPort ports,
    int speed,
    uint rampUpSteps,
    uint constantSteps,
    uint rampDownSteps,
    bool brake
)
public Task StepMotorAtSpeedAsync(
    OutputPort ports,
    int speed,
    uint rampUpSteps,
    uint constantSteps,
    uint rampDownSteps,
    bool brake
)
Public Function StepMotorAtSpeedAsync (
    ports As OutputPort,
    speed As Integer,
    rampUpSteps As UInteger,
    constantSteps As UInteger,
    rampDownSteps As UInteger,
    brake As Boolean
) As Task
Public Function StepMotorAtSpeedAsync (
    ports As OutputPort,
    speed As Integer,
    rampUpSteps As UInteger,
    constantSteps As UInteger,
    rampDownSteps As UInteger,
    brake As Boolean
) As Task
public:
Task^ StepMotorAtSpeedAsync(
    OutputPort ports,
    int speed,
    unsigned int rampUpSteps,
    unsigned int constantSteps,
    unsigned int rampDownSteps,
    bool brake
)
public:
Task^ StepMotorAtSpeedAsync(
    OutputPort ports,
    int speed,
    unsigned int rampUpSteps,
    unsigned int constantSteps,
    unsigned int rampDownSteps,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
A specific port or Ports.All.
speed
Type:   Online System Int32
The speed at which to turn the motor (-100 to 100).
rampUpSteps
Type:   Online System UInt32
[Missing <param name="rampUpSteps"/> documentation for "M:Lego.Ev3.Core.DirectCommand.StepMotorAtSpeedAsync(Lego.Ev3.Core.OutputPort,System.Int32,System.UInt32,System.UInt32,System.UInt32,System.Boolean)"]
constantSteps
Type:   Online System UInt32
[Missing <param name="constantSteps"/> documentation for "M:Lego.Ev3.Core.DirectCommand.StepMotorAtSpeedAsync(Lego.Ev3.Core.OutputPort,System.Int32,System.UInt32,System.UInt32,System.UInt32,System.Boolean)"]
rampDownSteps
Type:   Online System UInt32
[Missing <param name="rampDownSteps"/> documentation for "M:Lego.Ev3.Core.DirectCommand.StepMotorAtSpeedAsync(Lego.Ev3.Core.OutputPort,System.Int32,System.UInt32,System.UInt32,System.UInt32,System.Boolean)"]
brake
Type:   Online System Boolean
Apply brake to motor at end of routine.
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members
StepMotorAtSpeedAsync Overload


DirectCommand.StepMotorSyncAsync Method

DirectCommand StepMotorSyncAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Synchronize stepping of motors.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task StepMotorSyncAsync(
    OutputPort ports,
    int speed,
    short turnRatio,
    uint step,
    bool brake
)
public Task StepMotorSyncAsync(
    OutputPort ports,
    int speed,
    short turnRatio,
    uint step,
    bool brake
)
Public Function StepMotorSyncAsync (
    ports As OutputPort,
    speed As Integer,
    turnRatio As Short,
    step As UInteger,
    brake As Boolean
) As Task
Public Function StepMotorSyncAsync (
    ports As OutputPort,
    speed As Integer,
    turnRatio As Short,
    step As UInteger,
    brake As Boolean
) As Task
public:
Task^ StepMotorSyncAsync(
    OutputPort ports,
    int speed,
    short turnRatio,
    unsigned int step,
    bool brake
)
public:
Task^ StepMotorSyncAsync(
    OutputPort ports,
    int speed,
    short turnRatio,
    unsigned int step,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
The port or ports to which the stop command will be sent.
speed
Type:   Online System Int32
Speed to turn the motor(s).
turnRatio
Type:   Online System Int16
The turn ratio to apply.
step
Type:   Online System UInt32
The number of steps to turn the motor(s).
brake
Type:   Online System Boolean
Brake or coast at the end.
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.StopMotorAsync Method

DirectCommand StopMotorAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Stops motors on the specified ports.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task StopMotorAsync(
    OutputPort ports,
    bool brake
)
public Task StopMotorAsync(
    OutputPort ports,
    bool brake
)
Public Function StopMotorAsync (
    ports As OutputPort,
    brake As Boolean
) As Task
Public Function StopMotorAsync (
    ports As OutputPort,
    brake As Boolean
) As Task
public:
Task^ StopMotorAsync(
    OutputPort ports,
    bool brake
)
public:
Task^ StopMotorAsync(
    OutputPort ports,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
The port or ports to which the stop command will be sent.
brake
Type:   Online System Boolean
Apply brake to motor at end of routine.
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.TimeMotorSyncAsync Method

DirectCommand TimeMotorSyncAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Synchronize timing of motors.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task TimeMotorSyncAsync(
    OutputPort ports,
    int speed,
    short turnRatio,
    uint time,
    bool brake
)
public Task TimeMotorSyncAsync(
    OutputPort ports,
    int speed,
    short turnRatio,
    uint time,
    bool brake
)
Public Function TimeMotorSyncAsync (
    ports As OutputPort,
    speed As Integer,
    turnRatio As Short,
    time As UInteger,
    brake As Boolean
) As Task
Public Function TimeMotorSyncAsync (
    ports As OutputPort,
    speed As Integer,
    turnRatio As Short,
    time As UInteger,
    brake As Boolean
) As Task
public:
Task^ TimeMotorSyncAsync(
    OutputPort ports,
    int speed,
    short turnRatio,
    unsigned int time,
    bool brake
)
public:
Task^ TimeMotorSyncAsync(
    OutputPort ports,
    int speed,
    short turnRatio,
    unsigned int time,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
The port or ports to which the stop command will be sent.
speed
Type:   Online System Int32
Speed to turn the motor(s).
turnRatio
Type:   Online System Int16
The turn ratio to apply.
time
Type:   Online System UInt32
The time to turn the motor(s).
brake
Type:   Online System Boolean
Brake or coast at the end.
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.TurnMotorAtPowerAsync Method

DirectCommand TurnMotorAtPowerAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Turn the motor connected to the specified port or ports at the specified power.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task TurnMotorAtPowerAsync(
    OutputPort ports,
    int power
)
public Task TurnMotorAtPowerAsync(
    OutputPort ports,
    int power
)
Public Function TurnMotorAtPowerAsync (
    ports As OutputPort,
    power As Integer
) As Task
Public Function TurnMotorAtPowerAsync (
    ports As OutputPort,
    power As Integer
) As Task
public:
Task^ TurnMotorAtPowerAsync(
    OutputPort ports,
    int power
)
public:
Task^ TurnMotorAtPowerAsync(
    OutputPort ports,
    int power
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
A specific port or Ports.All.
power
Type:   Online System Int32
The power at which to turn the motor (-100 to 100).
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.TurnMotorAtPowerForTimeAsync Method

DirectCommand TurnMotorAtPowerForTimeAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Overload List
 | Name | Description
Public method | TurnMotorAtPowerForTimeAsync(OutputPort, Int32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified power for the specified times.
Public method | TurnMotorAtPowerForTimeAsync(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified power for the specified times.
Back to Top
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.TurnMotorAtPowerForTimeAsync Method (OutputPort, Int32, UInt32, Boolean)

DirectCommand TurnMotorAtPowerForTimeAsync Method (OutputPort, Int32, UInt32, Boolean) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Turn the motor connected to the specified port or ports at the specified power for the specified times.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task TurnMotorAtPowerForTimeAsync(
    OutputPort ports,
    int power,
    uint milliseconds,
    bool brake
)
public Task TurnMotorAtPowerForTimeAsync(
    OutputPort ports,
    int power,
    uint milliseconds,
    bool brake
)
Public Function TurnMotorAtPowerForTimeAsync (
    ports As OutputPort,
    power As Integer,
    milliseconds As UInteger,
    brake As Boolean
) As Task
Public Function TurnMotorAtPowerForTimeAsync (
    ports As OutputPort,
    power As Integer,
    milliseconds As UInteger,
    brake As Boolean
) As Task
public:
Task^ TurnMotorAtPowerForTimeAsync(
    OutputPort ports,
    int power,
    unsigned int milliseconds,
    bool brake
)
public:
Task^ TurnMotorAtPowerForTimeAsync(
    OutputPort ports,
    int power,
    unsigned int milliseconds,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
A specific port or Ports.All.
power
Type:   Online System Int32
The power at which to turn the motor (-100 to 100).
milliseconds
Type:   Online System UInt32
Number of milliseconds to run at constant power.
brake
Type:   Online System Boolean
Apply brake to motor at end of routine.
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members
TurnMotorAtPowerForTimeAsync Overload


DirectCommand.TurnMotorAtPowerForTimeAsync Method (OutputPort, Int32, UInt32, UInt32, UInt32, Boolean)

DirectCommand TurnMotorAtPowerForTimeAsync Method (OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Turn the motor connected to the specified port or ports at the specified power for the specified times.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task TurnMotorAtPowerForTimeAsync(
    OutputPort ports,
    int power,
    uint msRampUp,
    uint msConstant,
    uint msRampDown,
    bool brake
)
public Task TurnMotorAtPowerForTimeAsync(
    OutputPort ports,
    int power,
    uint msRampUp,
    uint msConstant,
    uint msRampDown,
    bool brake
)
Public Function TurnMotorAtPowerForTimeAsync (
    ports As OutputPort,
    power As Integer,
    msRampUp As UInteger,
    msConstant As UInteger,
    msRampDown As UInteger,
    brake As Boolean
) As Task
Public Function TurnMotorAtPowerForTimeAsync (
    ports As OutputPort,
    power As Integer,
    msRampUp As UInteger,
    msConstant As UInteger,
    msRampDown As UInteger,
    brake As Boolean
) As Task
public:
Task^ TurnMotorAtPowerForTimeAsync(
    OutputPort ports,
    int power,
    unsigned int msRampUp,
    unsigned int msConstant,
    unsigned int msRampDown,
    bool brake
)
public:
Task^ TurnMotorAtPowerForTimeAsync(
    OutputPort ports,
    int power,
    unsigned int msRampUp,
    unsigned int msConstant,
    unsigned int msRampDown,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
A specific port or Ports.All.
power
Type:   Online System Int32
The power at which to turn the motor (-100 to 100).
msRampUp
Type:   Online System UInt32
Number of milliseconds to get up to power.
msConstant
Type:   Online System UInt32
Number of milliseconds to run at constant power.
msRampDown
Type:   Online System UInt32
Number of milliseconds to power down to a stop.
brake
Type:   Online System Boolean
Apply brake to motor at end of routine.
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members
TurnMotorAtPowerForTimeAsync Overload


DirectCommand.TurnMotorAtSpeedAsync Method

DirectCommand TurnMotorAtSpeedAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Turn the specified motor at the specified speed.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task TurnMotorAtSpeedAsync(
    OutputPort ports,
    int speed
)
public Task TurnMotorAtSpeedAsync(
    OutputPort ports,
    int speed
)
Public Function TurnMotorAtSpeedAsync (
    ports As OutputPort,
    speed As Integer
) As Task
Public Function TurnMotorAtSpeedAsync (
    ports As OutputPort,
    speed As Integer
) As Task
public:
Task^ TurnMotorAtSpeedAsync(
    OutputPort ports,
    int speed
)
public:
Task^ TurnMotorAtSpeedAsync(
    OutputPort ports,
    int speed
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
Port or ports to apply the command to.
speed
Type:   Online System Int32
The speed to apply to the specified motors (-100 to 100).
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.TurnMotorAtSpeedForTimeAsync Method

DirectCommand TurnMotorAtSpeedForTimeAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Overload List
 | Name | Description
Public method | TurnMotorAtSpeedForTimeAsync(OutputPort, Int32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified speed for the specified times.
Public method | TurnMotorAtSpeedForTimeAsync(OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) | Turn the motor connected to the specified port or ports at the specified speed for the specified times.
Back to Top
See Also
DirectCommand Class
DirectCommand Members


DirectCommand.TurnMotorAtSpeedForTimeAsync Method (OutputPort, Int32, UInt32, Boolean)

DirectCommand TurnMotorAtSpeedForTimeAsync Method (OutputPort, Int32, UInt32, Boolean) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Turn the motor connected to the specified port or ports at the specified speed for the specified times.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task TurnMotorAtSpeedForTimeAsync(
    OutputPort ports,
    int speed,
    uint milliseconds,
    bool brake
)
public Task TurnMotorAtSpeedForTimeAsync(
    OutputPort ports,
    int speed,
    uint milliseconds,
    bool brake
)
Public Function TurnMotorAtSpeedForTimeAsync (
    ports As OutputPort,
    speed As Integer,
    milliseconds As UInteger,
    brake As Boolean
) As Task
Public Function TurnMotorAtSpeedForTimeAsync (
    ports As OutputPort,
    speed As Integer,
    milliseconds As UInteger,
    brake As Boolean
) As Task
public:
Task^ TurnMotorAtSpeedForTimeAsync(
    OutputPort ports,
    int speed,
    unsigned int milliseconds,
    bool brake
)
public:
Task^ TurnMotorAtSpeedForTimeAsync(
    OutputPort ports,
    int speed,
    unsigned int milliseconds,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
A specific port or Ports.All.
speed
Type:   Online System Int32
The power at which to turn the motor (-100 to 100).
milliseconds
Type:   Online System UInt32
Number of milliseconds to run at constant speed.
brake
Type:   Online System Boolean
Apply brake to motor at end of routine.
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members
TurnMotorAtSpeedForTimeAsync Overload


DirectCommand.TurnMotorAtSpeedForTimeAsync Method (OutputPort, Int32, UInt32, UInt32, UInt32, Boolean)

DirectCommand TurnMotorAtSpeedForTimeAsync Method (OutputPort, Int32, UInt32, UInt32, UInt32, Boolean) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Turn the motor connected to the specified port or ports at the specified speed for the specified times.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task TurnMotorAtSpeedForTimeAsync(
    OutputPort ports,
    int speed,
    uint msRampUp,
    uint msConstant,
    uint msRampDown,
    bool brake
)
public Task TurnMotorAtSpeedForTimeAsync(
    OutputPort ports,
    int speed,
    uint msRampUp,
    uint msConstant,
    uint msRampDown,
    bool brake
)
Public Function TurnMotorAtSpeedForTimeAsync (
    ports As OutputPort,
    speed As Integer,
    msRampUp As UInteger,
    msConstant As UInteger,
    msRampDown As UInteger,
    brake As Boolean
) As Task
Public Function TurnMotorAtSpeedForTimeAsync (
    ports As OutputPort,
    speed As Integer,
    msRampUp As UInteger,
    msConstant As UInteger,
    msRampDown As UInteger,
    brake As Boolean
) As Task
public:
Task^ TurnMotorAtSpeedForTimeAsync(
    OutputPort ports,
    int speed,
    unsigned int msRampUp,
    unsigned int msConstant,
    unsigned int msRampDown,
    bool brake
)
public:
Task^ TurnMotorAtSpeedForTimeAsync(
    OutputPort ports,
    int speed,
    unsigned int msRampUp,
    unsigned int msConstant,
    unsigned int msRampDown,
    bool brake
)
Parameters
ports
Type: Lego.Ev3.Core OutputPort
A specific port or Ports.All.
speed
Type:   Online System Int32
The power at which to turn the motor (-100 to 100).
msRampUp
Type:   Online System UInt32
Number of milliseconds to get up to speed.
msConstant
Type:   Online System UInt32
Number of milliseconds to run at constant speed.
msRampDown
Type:   Online System UInt32
Number of milliseconds to slow down to a stop.
brake
Type:   Online System Boolean
Apply brake to motor at end of routine.
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members
TurnMotorAtSpeedForTimeAsync Overload


DirectCommand.UpdateUIAsync Method

DirectCommand UpdateUIAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Refresh the EV3 LCD screen

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task UpdateUIAsync()
public Task UpdateUIAsync()
Public Function UpdateUIAsync As Task
Public Function UpdateUIAsync As Task
public:
Task^ UpdateUIAsync()
public:
Task^ UpdateUIAsync()
Return Value
Type:   Online Task
See Also
DirectCommand Class
DirectCommand Members


DummyCommunication Class

DummyCommunication Class LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Dummy object for testing. Does not actually connect or communicate with EV3 brick.
Inheritance Hierarchy
Online System Object
Lego.Ev3.Core DummyCommunication

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class DummyCommunication : ICommunication
public sealed class DummyCommunication : ICommunication
Public NotInheritable Class DummyCommunication
    Implements ICommunication
Public NotInheritable Class DummyCommunication
    Implements ICommunication
public ref class DummyCommunication sealed : ICommunication
public ref class DummyCommunication sealed : ICommunication
See Also
DummyCommunication Members


DummyCommunication Members

DummyCommunication Members LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

The DummyCommunication type exposes the following members.
Constructors
 | Name | Description
Public method | DummyCommunication | Initializes a new instance of the DummyCommunication class
Back to Top
Methods
 | Name | Description
Public method | ConnectAsync | Test Connect method.
Public method | Disconnect | Test Disconnect method.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | WriteAsync | Test WriteAsync method. (Writes formatted data to Debug stream).
Back to Top
Events
 | Name | Description
Public event | ReportReceived | Event fired when a complete report is received from the EV3 brick. In this dummy implementation, the event is never fired.
Back to Top
See Also
DummyCommunication Class


DummyCommunication Constructor

DummyCommunication Constructor LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Initializes a new instance of the DummyCommunication class

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DummyCommunication()
public DummyCommunication()
Public Sub New
Public Sub New
public:
DummyCommunication()
public:
DummyCommunication()
See Also
DummyCommunication Class
DummyCommunication Members


DummyCommunication Methods

DummyCommunication Methods LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

The DummyCommunication type exposes the following members.
Methods
 | Name | Description
Public method | ConnectAsync | Test Connect method.
Public method | Disconnect | Test Disconnect method.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | WriteAsync | Test WriteAsync method. (Writes formatted data to Debug stream).
Back to Top
See Also
DummyCommunication Class


DummyCommunication.ConnectAsync Method

DummyCommunication ConnectAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Test Connect method.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task ConnectAsync()
public Task ConnectAsync()
Public Function ConnectAsync As Task
Public Function ConnectAsync As Task
public:
virtual Task^ ConnectAsync() sealed
public:
virtual Task^ ConnectAsync() sealed
Return Value
Type:   Online Task
Implements
ICommunication ConnectAsync
See Also
DummyCommunication Class
DummyCommunication Members


DummyCommunication.Disconnect Method

DummyCommunication Disconnect Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Test Disconnect method.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Disconnect()
public void Disconnect()
Public Sub Disconnect
Public Sub Disconnect
public:
virtual void Disconnect() sealed
public:
virtual void Disconnect() sealed
Implements
ICommunication Disconnect
See Also
DummyCommunication Class
DummyCommunication Members


DummyCommunication.WriteAsync Method

DummyCommunication WriteAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Test WriteAsync method. (Writes formatted data to Debug stream).

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task WriteAsync(
    byte[] data
)
public Task WriteAsync(
    byte[] data
)
Public Function WriteAsync (
    data As Byte()
) As Task
Public Function WriteAsync (
    data As Byte()
) As Task
public:
virtual Task^ WriteAsync(
    array<unsigned char>^ data
) sealed
public:
virtual Task^ WriteAsync(
    array<unsigned char>^ data
) sealed
Parameters
data
Type:    Online System Byte
Byte array to be written.
Return Value
Type:   Online Task
Implements
ICommunication WriteAsync( Byte )
See Also
DummyCommunication Class
DummyCommunication Members


DummyCommunication Events

DummyCommunication Events LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

The DummyCommunication type exposes the following members.
Events
 | Name | Description
Public event | ReportReceived | Event fired when a complete report is received from the EV3 brick. In this dummy implementation, the event is never fired.
Back to Top
See Also
DummyCommunication Class


DummyCommunication.ReportReceived Event

DummyCommunication ReportReceived Event LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Event fired when a complete report is received from the EV3 brick. In this dummy implementation, the event is never fired.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<ReportReceivedEventArgs> ReportReceived
public event EventHandler<ReportReceivedEventArgs> ReportReceived
Public Event ReportReceived As EventHandler(Of ReportReceivedEventArgs)
Public Event ReportReceived As EventHandler(Of ReportReceivedEventArgs)
public:
virtual  event EventHandler<ReportReceivedEventArgs^>^ ReportReceived {
    void add (EventHandler<ReportReceivedEventArgs^>^ value);
    void remove (EventHandler<ReportReceivedEventArgs^>^ value);
}
public:
virtual  event EventHandler<ReportReceivedEventArgs^>^ ReportReceived {
    void add (EventHandler<ReportReceivedEventArgs^>^ value);
    void remove (EventHandler<ReportReceivedEventArgs^>^ value);
}
Value
Type:   Online System EventHandler  ReportReceivedEventArgs
Implements
ICommunication ReportReceived
See Also
DummyCommunication Class
DummyCommunication Members


FontType Enumeration

FontType Enumeration LEGO Mindstorms EV3 API Documentation

Font types for drawing text to the screen

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum FontType
public enum FontType
Public Enumeration FontType
Public Enumeration FontType
public enum class FontType
public enum class FontType
Members
Member name | Value | Description
Small | 0 | Small font
Medium | 1 | Medium font
Large | 2 | Large font


Format Enumeration

Format Enumeration LEGO Mindstorms EV3 API Documentation

Format for sensor data.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum Format
public enum Format
Public Enumeration Format
Public Enumeration Format
public enum class Format
public enum class Format
Members
Member name | Value | Description
Percent | 16 | Percentage
Raw | 17 | Raw
SI | 18 | International System of Units


GyroscopeMode Enumeration

GyroscopeMode Enumeration LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

EV3 Gyroscope Sensor mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum GyroscopeMode
public enum GyroscopeMode
Public Enumeration GyroscopeMode
Public Enumeration GyroscopeMode
public enum class GyroscopeMode
public enum class GyroscopeMode
Members
Member name | Value | Description
Angle | 0 | Angle
Rate | 1 | Rate of movement
Fas | 2 | Unknown
GandA | 3 | Unknown
Calibrate | 4 | Calibrate


ICommunication Interface

ICommunication Interface LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Interface for communicating with the EV3 brick

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ICommunication
public interface ICommunication
Public Interface ICommunication
Public Interface ICommunication
public interface class ICommunication
public interface class ICommunication
See Also
ICommunication Members


ICommunication Members

ICommunication Members LEGO Mindstorms EV3 API Documentation

The ICommunication type exposes the following members.
Methods
 | Name | Description
Public method | ConnectAsync | Connect to the EV3 brick.
Public method | Disconnect | Disconnect from the EV3 brick.
Public method | WriteAsync | Write a report to the EV3 brick.
Back to Top
Events
 | Name | Description
Public event | ReportReceived | Fired when a full report is ready to parse and process.
Back to Top
See Also
ICommunication Interface


ICommunication Methods

ICommunication Methods LEGO Mindstorms EV3 API Documentation

The ICommunication type exposes the following members.
Methods
 | Name | Description
Public method | ConnectAsync | Connect to the EV3 brick.
Public method | Disconnect | Disconnect from the EV3 brick.
Public method | WriteAsync | Write a report to the EV3 brick.
Back to Top
See Also
ICommunication Interface


ICommunication.ConnectAsync Method

ICommunication ConnectAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Connect to the EV3 brick.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Task ConnectAsync()
Task ConnectAsync()
Function ConnectAsync As Task
Function ConnectAsync As Task
Task^ ConnectAsync()
Task^ ConnectAsync()
Return Value
Type:   Online Task
See Also
ICommunication Interface
ICommunication Members


ICommunication.Disconnect Method

ICommunication Disconnect Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Disconnect from the EV3 brick.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Disconnect()
void Disconnect()
Sub Disconnect
Sub Disconnect
void Disconnect()
void Disconnect()
See Also
ICommunication Interface
ICommunication Members


ICommunication.WriteAsync Method

ICommunication WriteAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Write a report to the EV3 brick.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Task WriteAsync(
    byte[] data
)
Task WriteAsync(
    byte[] data
)
Function WriteAsync (
    data As Byte()
) As Task
Function WriteAsync (
    data As Byte()
) As Task
Task^ WriteAsync(
    array<unsigned char>^ data
)
Task^ WriteAsync(
    array<unsigned char>^ data
)
Parameters
data
Type:    Online System Byte
[Missing <param name="data"/> documentation for "M:Lego.Ev3.Core.ICommunication.WriteAsync(System.Byte[])"]
Return Value
Type:   Online Task
See Also
ICommunication Interface
ICommunication Members


ICommunication Events

ICommunication Events LEGO Mindstorms EV3 API Documentation

The ICommunication type exposes the following members.
Events
 | Name | Description
Public event | ReportReceived | Fired when a full report is ready to parse and process.
Back to Top
See Also
ICommunication Interface


ICommunication.ReportReceived Event

ICommunication ReportReceived Event LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Fired when a full report is ready to parse and process.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
event EventHandler<ReportReceivedEventArgs> ReportReceived
event EventHandler<ReportReceivedEventArgs> ReportReceived
Event ReportReceived As EventHandler(Of ReportReceivedEventArgs)
Event ReportReceived As EventHandler(Of ReportReceivedEventArgs)
 event EventHandler<ReportReceivedEventArgs^>^ ReportReceived {
    void add (EventHandler<ReportReceivedEventArgs^>^ value);
    void remove (EventHandler<ReportReceivedEventArgs^>^ value);
}
 event EventHandler<ReportReceivedEventArgs^>^ ReportReceived {
    void add (EventHandler<ReportReceivedEventArgs^>^ value);
    void remove (EventHandler<ReportReceivedEventArgs^>^ value);
}
Value
Type:   Online System EventHandler  ReportReceivedEventArgs
See Also
ICommunication Interface
ICommunication Members


InfraredMode Enumeration

InfraredMode Enumeration LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

EV3 Infrared Sensor mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum InfraredMode
public enum InfraredMode
Public Enumeration InfraredMode
Public Enumeration InfraredMode
public enum class InfraredMode
public enum class InfraredMode
Members
Member name | Value | Description
Proximity | 0 | Proximity
Seek | 1 | Seek
Remote | 2 | EV3 remote control
RemoteA | 3 | Unknown
SAlt | 4 | Unknown
Calibrate | 5 | Calibrate


InputPort Enumeration

InputPort Enumeration LEGO Mindstorms EV3 API Documentation

Ports which can receive input data

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum InputPort
public enum InputPort
Public Enumeration InputPort
Public Enumeration InputPort
public enum class InputPort
public enum class InputPort
Members
Member name | Value | Description
One | 0 | Port 1
Two | 1 | Port 2
Three | 2 | Port 3
Four | 3 | Port 4
A | 16 | Port A
B | 17 | Port B
C | 18 | Port C
D | 19 | Port D


LedPattern Enumeration

LedPattern Enumeration LEGO Mindstorms EV3 API Documentation

Pattern to light up the EV3 brick's LED

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum LedPattern
public enum LedPattern
Public Enumeration LedPattern
Public Enumeration LedPattern
public enum class LedPattern
public enum class LedPattern
Members
Member name | Value | Description
Black | 0 | LED off
Green | 1 | Solid green
Red | 2 | Solid red
Orange | 3 | Solid orange
GreenFlash | 4 | Flashing green
RedFlash | 5 | Flashing red
OrangeFlash | 6 | Flashing orange
GreenPulse | 7 | Pulsing green
RedPulse | 8 | Pulsing red
OrangePulse | 9 | Pulsing orange


MotorMode Enumeration

MotorMode Enumeration LEGO Mindstorms EV3 API Documentation

Motor mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum MotorMode
public enum MotorMode
Public Enumeration MotorMode
Public Enumeration MotorMode
public enum class MotorMode
public enum class MotorMode
Members
Member name | Value | Description
Degrees | 0 | Values in degrees
Rotations | 1 | Values in rotations
Percent | 2 | Values in percentage


NxtColorMode Enumeration

NxtColorMode Enumeration LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

NXT Color Sensor mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum NxtColorMode
public enum NxtColorMode
Public Enumeration NxtColorMode
Public Enumeration NxtColorMode
public enum class NxtColorMode
public enum class NxtColorMode
Members
Member name | Value | Description
Reflective | 0 | Reflected color
Ambient | 1 | Ambient color
Color | 2 | Specific color
Green | 3 | Amount of green
Blue | 4 | Amount of blue
Raw | 5 | Raw sensor value


NxtLightMode Enumeration

NxtLightMode Enumeration LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

NXT Light Sensor mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum NxtLightMode
public enum NxtLightMode
Public Enumeration NxtLightMode
Public Enumeration NxtLightMode
public enum class NxtLightMode
public enum class NxtLightMode
Members
Member name | Value | Description
Reflect | 0 | Amount of reflected light
Ambient | 1 | Amoutn of ambient light


NxtSoundMode Enumeration

NxtSoundMode Enumeration LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

NXT Sound Sensor mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum NxtSoundMode
public enum NxtSoundMode
Public Enumeration NxtSoundMode
Public Enumeration NxtSoundMode
public enum class NxtSoundMode
public enum class NxtSoundMode
Members
Member name | Value | Description
Decibels | 0 | Decibels
AdjustedDecibels | 1 | Adjusted Decibels


NxtTemperatureMode Enumeration

NxtTemperatureMode Enumeration LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

NXT Temperature Sensor mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum NxtTemperatureMode
public enum NxtTemperatureMode
Public Enumeration NxtTemperatureMode
Public Enumeration NxtTemperatureMode
public enum class NxtTemperatureMode
public enum class NxtTemperatureMode
Members
Member name | Value | Description
Celsius | 0 | Values in Celsius units
Fahrenheit | 1 | Values in Fahrenheit units


NxtUltrasonicMode Enumeration

NxtUltrasonicMode Enumeration LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

NXT Ultrasonic Sensor mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum NxtUltrasonicMode
public enum NxtUltrasonicMode
Public Enumeration NxtUltrasonicMode
Public Enumeration NxtUltrasonicMode
public enum class NxtUltrasonicMode
public enum class NxtUltrasonicMode
Members
Member name | Value | Description
Centimeters | 0 | Values in centimeter units
Inches | 1 | Values in inch units


OutputPort Enumeration

OutputPort Enumeration LEGO Mindstorms EV3 API Documentation

Ports which can send output

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[FlagsAttribute]
public enum OutputPort
[FlagsAttribute]
public enum OutputPort
<FlagsAttribute>
Public Enumeration OutputPort
<FlagsAttribute>
Public Enumeration OutputPort
[FlagsAttribute]
public enum class OutputPort
[FlagsAttribute]
public enum class OutputPort
Members
Member name | Value | Description
A | 1 | Port A
B | 2 | Port B
C | 4 | Port C
D | 8 | Port D
All | 15 | Ports A,B,C and D simultaneously


Polarity Enumeration

Polarity Enumeration LEGO Mindstorms EV3 API Documentation

Polarity/direction to turn the motor

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum Polarity
public enum Polarity
Public Enumeration Polarity
Public Enumeration Polarity
public enum class Polarity
public enum class Polarity
Members
Member name | Value | Description
Backward | -1 | Turn backward
Opposite | 0 | Turn in the opposite direction
Forward | 1 | Turn forward


Port Class

Port Class LEGO Mindstorms EV3 API Documentation

An input or output port on the EV3 brick
Inheritance Hierarchy
Online System Object
Lego.Ev3.Core Port

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Port : INotifyPropertyChanged
public sealed class Port : INotifyPropertyChanged
Public NotInheritable Class Port
    Implements INotifyPropertyChanged
Public NotInheritable Class Port
    Implements INotifyPropertyChanged
public ref class Port sealed : INotifyPropertyChanged
public ref class Port sealed : INotifyPropertyChanged
See Also
Port Members


Port Members

Port Members LEGO Mindstorms EV3 API Documentation

The Port type exposes the following members.
Constructors
 | Name | Description
Public method | Port | Constructor
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetMode(Byte) | Set the connected sensor's mode
Public method | SetMode(ColorMode) | Set the connected sensor's mode
Public method | SetMode(GyroscopeMode) | Set the connected sensor's mode
Public method | SetMode(InfraredMode) | Set the connected sensor's mode
Public method | SetMode(MotorMode) | Set the connected sensor's mode
Public method | SetMode(NxtLightMode) | Set the connected sensor's mode
Public method | SetMode(NxtSoundMode) | Set the connected sensor's mode
Public method | SetMode(NxtTemperatureMode) | Set the connected sensor's mode
Public method | SetMode(NxtUltrasonicMode) | Set the connected sensor's mode
Public method | SetMode(TouchMode) | Set the connected sensor's mode
Public method | SetMode(UltrasonicMode) | Set the connected sensor's mode
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Mode | Device mode. Some devices work in multiple modes.
Public property | Name | Name of port.
Public property | PercentValue | Percentage value associated with the Port.
Public property | RawValue | Raw value associated with the Port.
Public property | SIValue | Current International System of Units value associated with the Port.
Public property | Type | Device plugged into port.
Back to Top
Events
 | Name | Description
Public event | PropertyChanged | INotifyProperty event
Back to Top
See Also
Port Class


Port Constructor

Port Constructor LEGO Mindstorms EV3 API Documentation

Constructor

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Port()
public Port()
Public Sub New
Public Sub New
public:
Port()
public:
Port()
See Also
Port Class
Port Members


Port Methods

Port Methods LEGO Mindstorms EV3 API Documentation

The Port type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetMode(Byte) | Set the connected sensor's mode
Public method | SetMode(ColorMode) | Set the connected sensor's mode
Public method | SetMode(GyroscopeMode) | Set the connected sensor's mode
Public method | SetMode(InfraredMode) | Set the connected sensor's mode
Public method | SetMode(MotorMode) | Set the connected sensor's mode
Public method | SetMode(NxtLightMode) | Set the connected sensor's mode
Public method | SetMode(NxtSoundMode) | Set the connected sensor's mode
Public method | SetMode(NxtTemperatureMode) | Set the connected sensor's mode
Public method | SetMode(NxtUltrasonicMode) | Set the connected sensor's mode
Public method | SetMode(TouchMode) | Set the connected sensor's mode
Public method | SetMode(UltrasonicMode) | Set the connected sensor's mode
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
Port Class


Port.SetMode Method

Port SetMode Method LEGO Mindstorms EV3 API Documentation

Overload List
 | Name | Description
Public method | SetMode(Byte) | Set the connected sensor's mode
Public method | SetMode(ColorMode) | Set the connected sensor's mode
Public method | SetMode(GyroscopeMode) | Set the connected sensor's mode
Public method | SetMode(InfraredMode) | Set the connected sensor's mode
Public method | SetMode(MotorMode) | Set the connected sensor's mode
Public method | SetMode(NxtLightMode) | Set the connected sensor's mode
Public method | SetMode(NxtSoundMode) | Set the connected sensor's mode
Public method | SetMode(NxtTemperatureMode) | Set the connected sensor's mode
Public method | SetMode(NxtUltrasonicMode) | Set the connected sensor's mode
Public method | SetMode(TouchMode) | Set the connected sensor's mode
Public method | SetMode(UltrasonicMode) | Set the connected sensor's mode
Back to Top
See Also
Port Class
Port Members


Port.SetMode Method (Byte)

Port SetMode Method (Byte) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Set the connected sensor's mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetMode(
    byte mode
)
public void SetMode(
    byte mode
)
Public Sub SetMode (
    mode As Byte
)
Public Sub SetMode (
    mode As Byte
)
public:
void SetMode(
    unsigned char mode
)
public:
void SetMode(
    unsigned char mode
)
Parameters
mode
Type:   Online System Byte
The requested mode.
See Also
Port Class
Port Members
SetMode Overload


Port.SetMode Method (ColorMode)

Port SetMode Method (ColorMode) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Set the connected sensor's mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetMode(
    ColorMode mode
)
public void SetMode(
    ColorMode mode
)
Public Sub SetMode (
    mode As ColorMode
)
Public Sub SetMode (
    mode As ColorMode
)
public:
void SetMode(
    ColorMode mode
)
public:
void SetMode(
    ColorMode mode
)
Parameters
mode
Type: Lego.Ev3.Core ColorMode
The requested mode.
See Also
Port Class
Port Members
SetMode Overload


Port.SetMode Method (GyroscopeMode)

Port SetMode Method (GyroscopeMode) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Set the connected sensor's mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetMode(
    GyroscopeMode mode
)
public void SetMode(
    GyroscopeMode mode
)
Public Sub SetMode (
    mode As GyroscopeMode
)
Public Sub SetMode (
    mode As GyroscopeMode
)
public:
void SetMode(
    GyroscopeMode mode
)
public:
void SetMode(
    GyroscopeMode mode
)
Parameters
mode
Type: Lego.Ev3.Core GyroscopeMode
The requested mode.
See Also
Port Class
Port Members
SetMode Overload


Port.SetMode Method (InfraredMode)

Port SetMode Method (InfraredMode) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Set the connected sensor's mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetMode(
    InfraredMode mode
)
public void SetMode(
    InfraredMode mode
)
Public Sub SetMode (
    mode As InfraredMode
)
Public Sub SetMode (
    mode As InfraredMode
)
public:
void SetMode(
    InfraredMode mode
)
public:
void SetMode(
    InfraredMode mode
)
Parameters
mode
Type: Lego.Ev3.Core InfraredMode
The requested mode.
See Also
Port Class
Port Members
SetMode Overload


Port.SetMode Method (MotorMode)

Port SetMode Method (MotorMode) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Set the connected sensor's mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetMode(
    MotorMode mode
)
public void SetMode(
    MotorMode mode
)
Public Sub SetMode (
    mode As MotorMode
)
Public Sub SetMode (
    mode As MotorMode
)
public:
void SetMode(
    MotorMode mode
)
public:
void SetMode(
    MotorMode mode
)
Parameters
mode
Type: Lego.Ev3.Core MotorMode
The requested mode.
See Also
Port Class
Port Members
SetMode Overload


Port.SetMode Method (NxtLightMode)

Port SetMode Method (NxtLightMode) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Set the connected sensor's mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetMode(
    NxtLightMode mode
)
public void SetMode(
    NxtLightMode mode
)
Public Sub SetMode (
    mode As NxtLightMode
)
Public Sub SetMode (
    mode As NxtLightMode
)
public:
void SetMode(
    NxtLightMode mode
)
public:
void SetMode(
    NxtLightMode mode
)
Parameters
mode
Type: Lego.Ev3.Core NxtLightMode
The requested mode.
See Also
Port Class
Port Members
SetMode Overload


Port.SetMode Method (NxtSoundMode)

Port SetMode Method (NxtSoundMode) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Set the connected sensor's mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetMode(
    NxtSoundMode mode
)
public void SetMode(
    NxtSoundMode mode
)
Public Sub SetMode (
    mode As NxtSoundMode
)
Public Sub SetMode (
    mode As NxtSoundMode
)
public:
void SetMode(
    NxtSoundMode mode
)
public:
void SetMode(
    NxtSoundMode mode
)
Parameters
mode
Type: Lego.Ev3.Core NxtSoundMode
The requested mode.
See Also
Port Class
Port Members
SetMode Overload


Port.SetMode Method (NxtTemperatureMode)

Port SetMode Method (NxtTemperatureMode) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Set the connected sensor's mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetMode(
    NxtTemperatureMode mode
)
public void SetMode(
    NxtTemperatureMode mode
)
Public Sub SetMode (
    mode As NxtTemperatureMode
)
Public Sub SetMode (
    mode As NxtTemperatureMode
)
public:
void SetMode(
    NxtTemperatureMode mode
)
public:
void SetMode(
    NxtTemperatureMode mode
)
Parameters
mode
Type: Lego.Ev3.Core NxtTemperatureMode
The requested mode.
See Also
Port Class
Port Members
SetMode Overload


Port.SetMode Method (NxtUltrasonicMode)

Port SetMode Method (NxtUltrasonicMode) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Set the connected sensor's mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetMode(
    NxtUltrasonicMode mode
)
public void SetMode(
    NxtUltrasonicMode mode
)
Public Sub SetMode (
    mode As NxtUltrasonicMode
)
Public Sub SetMode (
    mode As NxtUltrasonicMode
)
public:
void SetMode(
    NxtUltrasonicMode mode
)
public:
void SetMode(
    NxtUltrasonicMode mode
)
Parameters
mode
Type: Lego.Ev3.Core NxtUltrasonicMode
The requested mode.
See Also
Port Class
Port Members
SetMode Overload


Port.SetMode Method (TouchMode)

Port SetMode Method (TouchMode) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Set the connected sensor's mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetMode(
    TouchMode mode
)
public void SetMode(
    TouchMode mode
)
Public Sub SetMode (
    mode As TouchMode
)
Public Sub SetMode (
    mode As TouchMode
)
public:
void SetMode(
    TouchMode mode
)
public:
void SetMode(
    TouchMode mode
)
Parameters
mode
Type: Lego.Ev3.Core TouchMode
The requested mode.
See Also
Port Class
Port Members
SetMode Overload


Port.SetMode Method (UltrasonicMode)

Port SetMode Method (UltrasonicMode) LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Set the connected sensor's mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetMode(
    UltrasonicMode mode
)
public void SetMode(
    UltrasonicMode mode
)
Public Sub SetMode (
    mode As UltrasonicMode
)
Public Sub SetMode (
    mode As UltrasonicMode
)
public:
void SetMode(
    UltrasonicMode mode
)
public:
void SetMode(
    UltrasonicMode mode
)
Parameters
mode
Type: Lego.Ev3.Core UltrasonicMode
The requested mode.
See Also
Port Class
Port Members
SetMode Overload


Port Properties

Port Properties LEGO Mindstorms EV3 API Documentation

The Port type exposes the following members.
Properties
 | Name | Description
Public property | Mode | Device mode. Some devices work in multiple modes.
Public property | Name | Name of port.
Public property | PercentValue | Percentage value associated with the Port.
Public property | RawValue | Raw value associated with the Port.
Public property | SIValue | Current International System of Units value associated with the Port.
Public property | Type | Device plugged into port.
Back to Top
See Also
Port Class


Port.Mode Property

Port Mode Property LEGO Mindstorms EV3 API Documentation

Device mode. Some devices work in multiple modes.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte Mode { get; private set; }
public byte Mode { get; private set; }
Public Property Mode As Byte
    Get
    Private Set
Public Property Mode As Byte
    Get
    Private Set
public:
property unsigned char Mode {
    unsigned char get ();
    private: void set (unsigned char value);
}
public:
property unsigned char Mode {
    unsigned char get ();
    private: void set (unsigned char value);
}
Property Value
Type:   Online Byte
See Also
Port Class
Port Members


Port.Name Property

Port Name Property LEGO Mindstorms EV3 API Documentation

Name of port.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
Public Property Name As String
    Get
    Set
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
See Also
Port Class
Port Members


Port.PercentValue Property

Port PercentValue Property LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Percentage value associated with the Port.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte PercentValue { get; set; }
public byte PercentValue { get; set; }
Public Property PercentValue As Byte
    Get
    Set
Public Property PercentValue As Byte
    Get
    Set
public:
property unsigned char PercentValue {
    unsigned char get ();
    void set (unsigned char value);
}
public:
property unsigned char PercentValue {
    unsigned char get ();
    void set (unsigned char value);
}
Property Value
Type:   Online Byte
See Also
Port Class
Port Members


Port.RawValue Property

Port RawValue Property LEGO Mindstorms EV3 API Documentation

Raw value associated with the Port.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int RawValue { get; set; }
public int RawValue { get; set; }
Public Property RawValue As Integer
    Get
    Set
Public Property RawValue As Integer
    Get
    Set
public:
property int RawValue {
    int get ();
    void set (int value);
}
public:
property int RawValue {
    int get ();
    void set (int value);
}
Property Value
Type:   Online Int32
See Also
Port Class
Port Members


Port.SIValue Property

Port SIValue Property LEGO Mindstorms EV3 API Documentation

Current International System of Units value associated with the Port.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float SIValue { get; set; }
public float SIValue { get; set; }
Public Property SIValue As Single
    Get
    Set
Public Property SIValue As Single
    Get
    Set
public:
property float SIValue {
    float get ();
    void set (float value);
}
public:
property float SIValue {
    float get ();
    void set (float value);
}
Property Value
Type:   Online Single
See Also
Port Class
Port Members


Port.Type Property

Port Type Property LEGO Mindstorms EV3 API Documentation

Device plugged into port.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DeviceType Type { get; set; }
public DeviceType Type { get; set; }
Public Property Type As DeviceType
    Get
    Set
Public Property Type As DeviceType
    Get
    Set
public:
property DeviceType Type {
    DeviceType get ();
    void set (DeviceType value);
}
public:
property DeviceType Type {
    DeviceType get ();
    void set (DeviceType value);
}
Property Value
Type: DeviceType
See Also
Port Class
Port Members


Port Events

Port Events LEGO Mindstorms EV3 API Documentation

The Port type exposes the following members.
Events
 | Name | Description
Public event | PropertyChanged | INotifyProperty event
Back to Top
See Also
Port Class


Port.PropertyChanged Event

Port PropertyChanged Event LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

INotifyProperty event

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event PropertyChangedEventHandler PropertyChanged
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
Value
Type:   Online System.ComponentModel PropertyChangedEventHandler
Implements
  Online INotifyPropertyChanged PropertyChanged
See Also
Port Class
Port Members


ReportReceivedEventArgs Class

ReportReceivedEventArgs Class LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Event arguments for the ReportReceived event.
Inheritance Hierarchy
Online System Object
Online System EventArgs
Lego.Ev3.Core ReportReceivedEventArgs

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ReportReceivedEventArgs : EventArgs
public sealed class ReportReceivedEventArgs : EventArgs
Public NotInheritable Class ReportReceivedEventArgs
    Inherits EventArgs
Public NotInheritable Class ReportReceivedEventArgs
    Inherits EventArgs
public ref class ReportReceivedEventArgs sealed : public EventArgs
public ref class ReportReceivedEventArgs sealed : public EventArgs
See Also
ReportReceivedEventArgs Members


ReportReceivedEventArgs Members

ReportReceivedEventArgs Members LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

The ReportReceivedEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | ReportReceivedEventArgs | Initializes a new instance of the ReportReceivedEventArgs class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Report | Byte array of the data received from the EV3 brick.
Back to Top
See Also
ReportReceivedEventArgs Class


ReportReceivedEventArgs Constructor

ReportReceivedEventArgs Constructor LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Initializes a new instance of the ReportReceivedEventArgs class

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ReportReceivedEventArgs()
public ReportReceivedEventArgs()
Public Sub New
Public Sub New
public:
ReportReceivedEventArgs()
public:
ReportReceivedEventArgs()
See Also
ReportReceivedEventArgs Class
ReportReceivedEventArgs Members


ReportReceivedEventArgs Methods

ReportReceivedEventArgs Methods LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

The ReportReceivedEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
See Also
ReportReceivedEventArgs Class


ReportReceivedEventArgs Properties

ReportReceivedEventArgs Properties LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

The ReportReceivedEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Report | Byte array of the data received from the EV3 brick.
Back to Top
See Also
ReportReceivedEventArgs Class


ReportReceivedEventArgs.Report Property

ReportReceivedEventArgs Report Property LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Byte array of the data received from the EV3 brick.

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] Report { get; set; }
public byte[] Report { get; set; }
Public Property Report As Byte()
    Get
    Set
Public Property Report As Byte()
    Get
    Set
public:
property array<unsigned char>^ Report {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
public:
property array<unsigned char>^ Report {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
Property Value
Type:    Online Byte
See Also
ReportReceivedEventArgs Class
ReportReceivedEventArgs Members


SystemCommand Class

SystemCommand Class LEGO Mindstorms EV3 API Documentation

Direct commands for the EV3 brick
Inheritance Hierarchy
Online System Object
Lego.Ev3.Core SystemCommand

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class SystemCommand
public sealed class SystemCommand
Public NotInheritable Class SystemCommand
Public NotInheritable Class SystemCommand
public ref class SystemCommand sealed
public ref class SystemCommand sealed
See Also
SystemCommand Members


SystemCommand Members

SystemCommand Members LEGO Mindstorms EV3 API Documentation

The SystemCommand type exposes the following members.
Methods
 | Name | Description
Public method | CopyFileAsync | Copy a local file to the EV3 brick
Public method | CreateDirectoryAsync | Create a directory on the EV3 brick
Public method | DeleteFileAsync | Delete file from the EV3 brick
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | WriteFileAsync | Write a file to the EV3 brick
Back to Top
See Also
SystemCommand Class


SystemCommand Methods

SystemCommand Methods LEGO Mindstorms EV3 API Documentation

The SystemCommand type exposes the following members.
Methods
 | Name | Description
Public method | CopyFileAsync | Copy a local file to the EV3 brick
Public method | CreateDirectoryAsync | Create a directory on the EV3 brick
Public method | DeleteFileAsync | Delete file from the EV3 brick
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | WriteFileAsync | Write a file to the EV3 brick
Back to Top
See Also
SystemCommand Class


SystemCommand.CopyFileAsync Method

SystemCommand CopyFileAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Copy a local file to the EV3 brick

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task CopyFileAsync(
    string localPath,
    string devicePath
)
public Task CopyFileAsync(
    string localPath,
    string devicePath
)
Public Function CopyFileAsync (
    localPath As String,
    devicePath As String
) As Task
Public Function CopyFileAsync (
    localPath As String,
    devicePath As String
) As Task
public:
Task^ CopyFileAsync(
    String^ localPath,
    String^ devicePath
)
public:
Task^ CopyFileAsync(
    String^ localPath,
    String^ devicePath
)
Parameters
localPath
Type:   Online System String
Source path on the computer.
devicePath
Type:   Online System String
Destination path on the brick.
Return Value
Type:   Online Task
Remarks
devicePath is relative from "lms2012/sys" on the EV3 brick.  Destination folders are automatically created if provided in the path.  The path must start with "apps", "prjs", or "tools".
See Also
SystemCommand Class
SystemCommand Members


SystemCommand.CreateDirectoryAsync Method

SystemCommand CreateDirectoryAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Create a directory on the EV3 brick

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task CreateDirectoryAsync(
    string devicePath
)
public Task CreateDirectoryAsync(
    string devicePath
)
Public Function CreateDirectoryAsync (
    devicePath As String
) As Task
Public Function CreateDirectoryAsync (
    devicePath As String
) As Task
public:
Task^ CreateDirectoryAsync(
    String^ devicePath
)
public:
Task^ CreateDirectoryAsync(
    String^ devicePath
)
Parameters
devicePath
Type:   Online System String
Destination path on the brick.
Return Value
Type:   Online Task
Remarks
devicePath is relative from "lms2012/sys" on the EV3 brick.  Destination folders are automatically created if provided in the path.  The path must start with "apps", "prjs", or "tools".
See Also
SystemCommand Class
SystemCommand Members


SystemCommand.DeleteFileAsync Method

SystemCommand DeleteFileAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Delete file from the EV3 brick

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task DeleteFileAsync(
    string devicePath
)
public Task DeleteFileAsync(
    string devicePath
)
Public Function DeleteFileAsync (
    devicePath As String
) As Task
Public Function DeleteFileAsync (
    devicePath As String
) As Task
public:
Task^ DeleteFileAsync(
    String^ devicePath
)
public:
Task^ DeleteFileAsync(
    String^ devicePath
)
Parameters
devicePath
Type:   Online System String
Destination path on the brick.
Return Value
Type:   Online Task
Remarks
devicePath is relative from "lms2012/sys" on the EV3 brick.  The path must start with "apps", "prjs", or "tools".
See Also
SystemCommand Class
SystemCommand Members


SystemCommand.WriteFileAsync Method

SystemCommand WriteFileAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Write a file to the EV3 brick

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task WriteFileAsync(
    byte[] data,
    string devicePath
)
public Task WriteFileAsync(
    byte[] data,
    string devicePath
)
Public Function WriteFileAsync (
    data As Byte(),
    devicePath As String
) As Task
Public Function WriteFileAsync (
    data As Byte(),
    devicePath As String
) As Task
public:
Task^ WriteFileAsync(
    array<unsigned char>^ data,
    String^ devicePath
)
public:
Task^ WriteFileAsync(
    array<unsigned char>^ data,
    String^ devicePath
)
Parameters
data
Type:    Online System Byte
Data to write.
devicePath
Type:   Online System String
Destination path on the brick.
Return Value
Type:   Online Task
Remarks
devicePath is relative from "lms2012/sys" on the EV3 brick.  Destination folders are automatically created if provided in the path.  The path must start with "apps", "prjs", or "tools".
See Also
SystemCommand Class
SystemCommand Members


TouchMode Enumeration

TouchMode Enumeration LEGO Mindstorms EV3 API Documentation

NXT and EV3 Touch Sensor mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum TouchMode
public enum TouchMode
Public Enumeration TouchMode
Public Enumeration TouchMode
public enum class TouchMode
public enum class TouchMode
Members
Member name | Value | Description
Touch | 0 | On when pressed, off when released
Bumps | 1 | Running counter of number of presses


UltrasonicMode Enumeration

UltrasonicMode Enumeration LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

EV3 Ultrasonic Sensor mode

Namespace: Lego.Ev3.Core
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum UltrasonicMode
public enum UltrasonicMode
Public Enumeration UltrasonicMode
Public Enumeration UltrasonicMode
public enum class UltrasonicMode
public enum class UltrasonicMode
Members
Member name | Value | Description
Centimeters | 0 | Values in centimeter units
Inches | 1 | Values in inch units
Listen | 2 | Listen mode
SiCentimeters | 3 | Unknown
SiInches | 4 | Unknown
DcCentimeters | 5 | Unknown
DcInches | 6 | Unknown


Lego.Ev3.Desktop Namespace

Lego.Ev3.Desktop Namespace LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Classes for the Desktop API only.
Classes
 | Class | Description
Public class | BluetoothCommunication | Communicate to EV3 brick over Bluetooth
Public class | NetworkCommunication | Communicate with EV3 brick over TCP
Public class | UsbCommunication | Communicate with EV3 brick over USB HID.


BluetoothCommunication Class

BluetoothCommunication Class LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Communicate to EV3 brick over Bluetooth
Inheritance Hierarchy
Online System Object
Lego.Ev3.Desktop BluetoothCommunication

Namespace: Lego.Ev3.Desktop
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class BluetoothCommunication : ICommunication
public class BluetoothCommunication : ICommunication
Public Class BluetoothCommunication
    Implements ICommunication
Public Class BluetoothCommunication
    Implements ICommunication
public ref class BluetoothCommunication : ICommunication
public ref class BluetoothCommunication : ICommunication
See Also
BluetoothCommunication Members
Lego.Ev3.Desktop Namespace


BluetoothCommunication Members

BluetoothCommunication Members LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

The BluetoothCommunication type exposes the following members.
Constructors
 | Name | Description
Public method | BluetoothCommunication | Initialize a BluetoothCommunication object.
Back to Top
Methods
 | Name | Description
Public method | ConnectAsync | Connect to the EV3 brick.
Public method | Disconnect | Disconnect from the EV3 brick.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | WriteAsync | Write data to the EV3 brick.
Back to Top
Events
 | Name | Description
Public event | ReportReceived | Event fired when a complete report is received from the EV3 brick.
Back to Top
See Also
BluetoothCommunication Class
Lego.Ev3.Desktop Namespace


BluetoothCommunication Constructor

BluetoothCommunication Constructor LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Initialize a BluetoothCommunication object.

Namespace: Lego.Ev3.Desktop
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BluetoothCommunication(
    string port
)
public BluetoothCommunication(
    string port
)
Public Sub New (
    port As String
)
Public Sub New (
    port As String
)
public:
BluetoothCommunication(
    String^ port
)
public:
BluetoothCommunication(
    String^ port
)
Parameters
port
Type:   Online System String
The COM port on which to connect.
See Also
BluetoothCommunication Class
BluetoothCommunication Members
Lego.Ev3.Desktop Namespace


BluetoothCommunication Methods

BluetoothCommunication Methods LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

The BluetoothCommunication type exposes the following members.
Methods
 | Name | Description
Public method | ConnectAsync | Connect to the EV3 brick.
Public method | Disconnect | Disconnect from the EV3 brick.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | WriteAsync | Write data to the EV3 brick.
Back to Top
See Also
BluetoothCommunication Class
Lego.Ev3.Desktop Namespace


BluetoothCommunication.ConnectAsync Method

BluetoothCommunication ConnectAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Connect to the EV3 brick.

Namespace: Lego.Ev3.Desktop
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task ConnectAsync()
public Task ConnectAsync()
Public Function ConnectAsync As Task
Public Function ConnectAsync As Task
public:
virtual Task^ ConnectAsync() sealed
public:
virtual Task^ ConnectAsync() sealed
Return Value
Type:   Online Task
Implements
ICommunication ConnectAsync
See Also
BluetoothCommunication Class
BluetoothCommunication Members
Lego.Ev3.Desktop Namespace


BluetoothCommunication.Disconnect Method

BluetoothCommunication Disconnect Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Disconnect from the EV3 brick.

Namespace: Lego.Ev3.Desktop
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Disconnect()
public void Disconnect()
Public Sub Disconnect
Public Sub Disconnect
public:
virtual void Disconnect() sealed
public:
virtual void Disconnect() sealed
Implements
ICommunication Disconnect
See Also
BluetoothCommunication Class
BluetoothCommunication Members
Lego.Ev3.Desktop Namespace


BluetoothCommunication.WriteAsync Method

BluetoothCommunication WriteAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Write data to the EV3 brick.

Namespace: Lego.Ev3.Desktop
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task WriteAsync(
    byte[] data
)
public Task WriteAsync(
    byte[] data
)
Public Function WriteAsync (
    data As Byte()
) As Task
Public Function WriteAsync (
    data As Byte()
) As Task
public:
virtual Task^ WriteAsync(
    array<unsigned char>^ data
) sealed
public:
virtual Task^ WriteAsync(
    array<unsigned char>^ data
) sealed
Parameters
data
Type:    Online System Byte
Byte array of data to send to the EV3 brick.
Return Value
Type:   Online Task
Implements
ICommunication WriteAsync( Byte )
See Also
BluetoothCommunication Class
BluetoothCommunication Members
Lego.Ev3.Desktop Namespace


BluetoothCommunication Events

BluetoothCommunication Events LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

The BluetoothCommunication type exposes the following members.
Events
 | Name | Description
Public event | ReportReceived | Event fired when a complete report is received from the EV3 brick.
Back to Top
See Also
BluetoothCommunication Class
Lego.Ev3.Desktop Namespace


BluetoothCommunication.ReportReceived Event

BluetoothCommunication ReportReceived Event LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Event fired when a complete report is received from the EV3 brick.

Namespace: Lego.Ev3.Desktop
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<ReportReceivedEventArgs> ReportReceived
public event EventHandler<ReportReceivedEventArgs> ReportReceived
Public Event ReportReceived As EventHandler(Of ReportReceivedEventArgs)
Public Event ReportReceived As EventHandler(Of ReportReceivedEventArgs)
public:
virtual  event EventHandler<ReportReceivedEventArgs^>^ ReportReceived {
    void add (EventHandler<ReportReceivedEventArgs^>^ value);
    void remove (EventHandler<ReportReceivedEventArgs^>^ value);
}
public:
virtual  event EventHandler<ReportReceivedEventArgs^>^ ReportReceived {
    void add (EventHandler<ReportReceivedEventArgs^>^ value);
    void remove (EventHandler<ReportReceivedEventArgs^>^ value);
}
Value
Type:   Online System EventHandler  ReportReceivedEventArgs
Implements
ICommunication ReportReceived
See Also
BluetoothCommunication Class
BluetoothCommunication Members
Lego.Ev3.Desktop Namespace


NetworkCommunication Class

NetworkCommunication Class LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Communicate with EV3 brick over TCP
Inheritance Hierarchy
Online System Object
Lego.Ev3.Desktop NetworkCommunication

Namespace: Lego.Ev3.Desktop
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NetworkCommunication : ICommunication
public class NetworkCommunication : ICommunication
Public Class NetworkCommunication
    Implements ICommunication
Public Class NetworkCommunication
    Implements ICommunication
public ref class NetworkCommunication : ICommunication
public ref class NetworkCommunication : ICommunication
See Also
NetworkCommunication Members
Lego.Ev3.Desktop Namespace


NetworkCommunication Members

NetworkCommunication Members LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

The NetworkCommunication type exposes the following members.
Constructors
 | Name | Description
Public method | NetworkCommunication | Create a new NetworkCommunication object
Back to Top
Methods
 | Name | Description
Public method | ConnectAsync | Connect to the EV3 brick.
Public method | Disconnect | Disconnect from the EV3 brick.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | WriteAsync | Write data to the EV3 brick.
Back to Top
Events
 | Name | Description
Public event | ReportReceived | Event fired when a complete report is received from the EV3 brick.
Back to Top
See Also
NetworkCommunication Class
Lego.Ev3.Desktop Namespace


NetworkCommunication Constructor

NetworkCommunication Constructor LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Create a new NetworkCommunication object

Namespace: Lego.Ev3.Desktop
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NetworkCommunication(
    string address
)
public NetworkCommunication(
    string address
)
Public Sub New (
    address As String
)
Public Sub New (
    address As String
)
public:
NetworkCommunication(
    String^ address
)
public:
NetworkCommunication(
    String^ address
)
Parameters
address
Type:   Online System String
The IP address of the EV3 brick
See Also
NetworkCommunication Class
NetworkCommunication Members
Lego.Ev3.Desktop Namespace


NetworkCommunication Methods

NetworkCommunication Methods LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

The NetworkCommunication type exposes the following members.
Methods
 | Name | Description
Public method | ConnectAsync | Connect to the EV3 brick.
Public method | Disconnect | Disconnect from the EV3 brick.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | WriteAsync | Write data to the EV3 brick.
Back to Top
See Also
NetworkCommunication Class
Lego.Ev3.Desktop Namespace


NetworkCommunication.ConnectAsync Method

NetworkCommunication ConnectAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Connect to the EV3 brick.

Namespace: Lego.Ev3.Desktop
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task ConnectAsync()
public Task ConnectAsync()
Public Function ConnectAsync As Task
Public Function ConnectAsync As Task
public:
virtual Task^ ConnectAsync() sealed
public:
virtual Task^ ConnectAsync() sealed
Return Value
Type:   Online Task
Implements
ICommunication ConnectAsync
See Also
NetworkCommunication Class
NetworkCommunication Members
Lego.Ev3.Desktop Namespace


NetworkCommunication.Disconnect Method

NetworkCommunication Disconnect Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Disconnect from the EV3 brick.

Namespace: Lego.Ev3.Desktop
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Disconnect()
public void Disconnect()
Public Sub Disconnect
Public Sub Disconnect
public:
virtual void Disconnect() sealed
public:
virtual void Disconnect() sealed
Implements
ICommunication Disconnect
See Also
NetworkCommunication Class
NetworkCommunication Members
Lego.Ev3.Desktop Namespace


NetworkCommunication.WriteAsync Method

NetworkCommunication WriteAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Write data to the EV3 brick.

Namespace: Lego.Ev3.Desktop
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task WriteAsync(
    byte[] data
)
public Task WriteAsync(
    byte[] data
)
Public Function WriteAsync (
    data As Byte()
) As Task
Public Function WriteAsync (
    data As Byte()
) As Task
public:
virtual Task^ WriteAsync(
    array<unsigned char>^ data
) sealed
public:
virtual Task^ WriteAsync(
    array<unsigned char>^ data
) sealed
Parameters
data
Type:    Online System Byte
Byte array to write to the EV3 brick.
Return Value
Type:   Online Task
Implements
ICommunication WriteAsync( Byte )
See Also
NetworkCommunication Class
NetworkCommunication Members
Lego.Ev3.Desktop Namespace


NetworkCommunication Events

NetworkCommunication Events LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

The NetworkCommunication type exposes the following members.
Events
 | Name | Description
Public event | ReportReceived | Event fired when a complete report is received from the EV3 brick.
Back to Top
See Also
NetworkCommunication Class
Lego.Ev3.Desktop Namespace


NetworkCommunication.ReportReceived Event

NetworkCommunication ReportReceived Event LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Event fired when a complete report is received from the EV3 brick.

Namespace: Lego.Ev3.Desktop
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<ReportReceivedEventArgs> ReportReceived
public event EventHandler<ReportReceivedEventArgs> ReportReceived
Public Event ReportReceived As EventHandler(Of ReportReceivedEventArgs)
Public Event ReportReceived As EventHandler(Of ReportReceivedEventArgs)
public:
virtual  event EventHandler<ReportReceivedEventArgs^>^ ReportReceived {
    void add (EventHandler<ReportReceivedEventArgs^>^ value);
    void remove (EventHandler<ReportReceivedEventArgs^>^ value);
}
public:
virtual  event EventHandler<ReportReceivedEventArgs^>^ ReportReceived {
    void add (EventHandler<ReportReceivedEventArgs^>^ value);
    void remove (EventHandler<ReportReceivedEventArgs^>^ value);
}
Value
Type:   Online System EventHandler  ReportReceivedEventArgs
Implements
ICommunication ReportReceived
See Also
NetworkCommunication Class
NetworkCommunication Members
Lego.Ev3.Desktop Namespace


UsbCommunication Class

UsbCommunication Class LEGO Mindstorms EV3 API Documentation

Communicate with EV3 brick over USB HID.
Inheritance Hierarchy
Online System Object
Lego.Ev3.Desktop UsbCommunication

Namespace: Lego.Ev3.Desktop
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class UsbCommunication : ICommunication
public class UsbCommunication : ICommunication
Public Class UsbCommunication
    Implements ICommunication
Public Class UsbCommunication
    Implements ICommunication
public ref class UsbCommunication : ICommunication
public ref class UsbCommunication : ICommunication
See Also
UsbCommunication Members
Lego.Ev3.Desktop Namespace


UsbCommunication Members

UsbCommunication Members LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

The UsbCommunication type exposes the following members.
Constructors
 | Name | Description
Public method | UsbCommunication | Initializes a new instance of the UsbCommunication class
Back to Top
Methods
 | Name | Description
Public method | ConnectAsync | Connect to the EV3 brick.
Public method | Disconnect | Disconnect from the EV3 brick.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | WriteAsync | Write data to the EV3 brick.
Back to Top
Events
 | Name | Description
Public event | ReportReceived | Event fired when a complete report is received from the EV3 brick.
Back to Top
See Also
UsbCommunication Class
Lego.Ev3.Desktop Namespace


UsbCommunication Constructor

UsbCommunication Constructor LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Initializes a new instance of the UsbCommunication class

Namespace: Lego.Ev3.Desktop
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public UsbCommunication()
public UsbCommunication()
Public Sub New
Public Sub New
public:
UsbCommunication()
public:
UsbCommunication()
See Also
UsbCommunication Class
UsbCommunication Members
Lego.Ev3.Desktop Namespace


UsbCommunication Methods

UsbCommunication Methods LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

The UsbCommunication type exposes the following members.
Methods
 | Name | Description
Public method | ConnectAsync | Connect to the EV3 brick.
Public method | Disconnect | Disconnect from the EV3 brick.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | WriteAsync | Write data to the EV3 brick.
Back to Top
See Also
UsbCommunication Class
Lego.Ev3.Desktop Namespace


UsbCommunication.ConnectAsync Method

UsbCommunication ConnectAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Connect to the EV3 brick.

Namespace: Lego.Ev3.Desktop
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task ConnectAsync()
public Task ConnectAsync()
Public Function ConnectAsync As Task
Public Function ConnectAsync As Task
public:
virtual Task^ ConnectAsync() sealed
public:
virtual Task^ ConnectAsync() sealed
Return Value
Type:   Online Task
Implements
ICommunication ConnectAsync
See Also
UsbCommunication Class
UsbCommunication Members
Lego.Ev3.Desktop Namespace


UsbCommunication.Disconnect Method

UsbCommunication Disconnect Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Disconnect from the EV3 brick.

Namespace: Lego.Ev3.Desktop
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Disconnect()
public void Disconnect()
Public Sub Disconnect
Public Sub Disconnect
public:
virtual void Disconnect() sealed
public:
virtual void Disconnect() sealed
Implements
ICommunication Disconnect
See Also
UsbCommunication Class
UsbCommunication Members
Lego.Ev3.Desktop Namespace


UsbCommunication.WriteAsync Method

UsbCommunication WriteAsync Method LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Write data to the EV3 brick.

Namespace: Lego.Ev3.Desktop
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task WriteAsync(
    byte[] data
)
public Task WriteAsync(
    byte[] data
)
Public Function WriteAsync (
    data As Byte()
) As Task
Public Function WriteAsync (
    data As Byte()
) As Task
public:
virtual Task^ WriteAsync(
    array<unsigned char>^ data
) sealed
public:
virtual Task^ WriteAsync(
    array<unsigned char>^ data
) sealed
Parameters
data
Type:    Online System Byte
Byte array to send to the EV3 brick.
Return Value
Type:   Online Task
Implements
ICommunication WriteAsync( Byte )
See Also
UsbCommunication Class
UsbCommunication Members
Lego.Ev3.Desktop Namespace


UsbCommunication Events

UsbCommunication Events LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

The UsbCommunication type exposes the following members.
Events
 | Name | Description
Public event | ReportReceived | Event fired when a complete report is received from the EV3 brick.
Back to Top
See Also
UsbCommunication Class
Lego.Ev3.Desktop Namespace


UsbCommunication.ReportReceived Event

UsbCommunication ReportReceived Event LEGO Mindstorms EV3 API Documentation
For more information, please see the Online CodePlex project page and the Online Getting Started guide.

Event fired when a complete report is received from the EV3 brick.

Namespace: Lego.Ev3.Desktop
Assembly: Lego.Ev3.Desktop (in Lego.Ev3.Desktop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<ReportReceivedEventArgs> ReportReceived
public event EventHandler<ReportReceivedEventArgs> ReportReceived
Public Event ReportReceived As EventHandler(Of ReportReceivedEventArgs)
Public Event ReportReceived As EventHandler(Of ReportReceivedEventArgs)
public:
virtual  event EventHandler<ReportReceivedEventArgs^>^ ReportReceived {
    void add (EventHandler<ReportReceivedEventArgs^>^ value);
    void remove (EventHandler<ReportReceivedEventArgs^>^ value);
}
public:
virtual  event EventHandler<ReportReceivedEventArgs^>^ ReportReceived {
    void add (EventHandler<ReportReceivedEventArgs^>^ value);
    void remove (EventHandler<ReportReceivedEventArgs^>^ value);
}
Value
Type:   Online System EventHandler  ReportReceivedEventArgs
Implements
ICommunication ReportReceived
See Also
UsbCommunication Class
UsbCommunication Members
Lego.Ev3.Desktop Namespace